aboutsummaryrefslogtreecommitdiff
path: root/science/netcdf
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2019-08-31 11:21:21 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2019-08-31 11:21:21 +0000
commitd8ba1456bad79b0d53965c8963ae8c6dff3ddba5 (patch)
tree7c8bc02156100a3d28ba938c25d437178249f502 /science/netcdf
parent0a568c8b0baae1b78d9d774ba044fb0cea3a9b90 (diff)
downloadports-d8ba1456bad79b0d53965c8963ae8c6dff3ddba5.tar.gz
ports-d8ba1456bad79b0d53965c8963ae8c6dff3ddba5.zip
Remove DAP option
Since curl is required, enable DAP unconditionally. PR: 239295 Reported by: Leon Dietrich <doralitze@chaotikum.org>
Notes
Notes: svn path=/head/; revision=510378
Diffstat (limited to 'science/netcdf')
-rw-r--r--science/netcdf/Makefile13
1 files changed, 6 insertions, 7 deletions
diff --git a/science/netcdf/Makefile b/science/netcdf/Makefile
index 42261a00466d..f51d0104db64 100644
--- a/science/netcdf/Makefile
+++ b/science/netcdf/Makefile
@@ -15,26 +15,25 @@ COMMENT= C library for machine-independent, array-oriented data access
LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/COPYRIGHT
-LIB_DEPENDS= libhdf5.so:science/hdf5
+LIB_DEPENDS= libcurl.so:ftp/curl \
+ libhdf5.so:science/hdf5
CONFLICTS_INSTALL= hdf-4.[0-9]* netcdf-3.[0-9]* netcdf3-3.[0-9]*
-OPTIONS_DEFINE= DAP DOCS DOXYGEN SZIP
-OPTIONS_DEFAULT=DAP SZIP
-DAP_DESC= Build DAP client and remote testing
+OPTIONS_DEFINE= DOCS DOXYGEN SZIP
+OPTIONS_DEFAULT=SZIP
SZIP_DESC= SZIP support (required if HDF5 was built with SZIP)
USES= gmake libtool localbase ncurses pathfix pkgconfig:run
-CONFIGURE_ARGS= --disable-filter-testing --enable-netcdf-4
+CONFIGURE_ARGS= --disable-filter-testing \
+ --enable-dap --enable-netcdf-4
CPPFLAGS+= -fPIC -DPIC
GNU_CONFIGURE= yes
INSTALL_TARGET= install-strip
TEST_TARGET= check
USE_LDCONFIG= yes
-DAP_CONFIGURE_ENABLE= dap
-DAP_LIB_DEPENDS= libcurl.so:ftp/curl
DOXYGEN_BUILD_DEPENDS= doxygen:devel/doxygen
DOXYGEN_CONFIGURE_ENABLE= doxygen
DOXYGEN_IMPLIES= DOCS