aboutsummaryrefslogtreecommitdiff
path: root/science/nifticlib
diff options
context:
space:
mode:
authorRaphael Kubo da Costa <rakuco@FreeBSD.org>2016-12-28 14:54:37 +0000
committerRaphael Kubo da Costa <rakuco@FreeBSD.org>2016-12-28 14:54:37 +0000
commit2fc2a89f33b69c3a9c76bd89db488960d332a9e9 (patch)
treed012e809c2f861bb2b3294d14e4d1c11b62bf331 /science/nifticlib
parentefbb9aafac73009bb23631380f54de13e8be3887 (diff)
downloadports-2fc2a89f33b69c3a9c76bd89db488960d332a9e9.tar.gz
ports-2fc2a89f33b69c3a9c76bd89db488960d332a9e9.zip
Pass -fPIC when building the port's static libraries.
This makes it possible to use those libraries with shared libraries on at least amd64. While here, set LICENSE and drop MAKE_JOBS_UNSAFE. PR: 209982 Submitted by: Jason Bacon <bacon4000@gmail.com> (maintainer) MFH: 2016Q4
Notes
Notes: svn path=/head/; revision=429778
Diffstat (limited to 'science/nifticlib')
-rw-r--r--science/nifticlib/Makefile5
-rw-r--r--science/nifticlib/files/patch-Makefile18
-rw-r--r--science/nifticlib/files/patch-examples-Makefile4
-rw-r--r--science/nifticlib/files/patch-utils-Makefile4
4 files changed, 16 insertions, 15 deletions
diff --git a/science/nifticlib/Makefile b/science/nifticlib/Makefile
index 94d105d8f533..81fbf17c746e 100644
--- a/science/nifticlib/Makefile
+++ b/science/nifticlib/Makefile
@@ -3,13 +3,14 @@
PORTNAME= nifticlib
PORTVERSION= 2.0.0
+PORTREVISION= 1
CATEGORIES= science graphics
MASTER_SITES= SF/niftilib/nifticlib/nifticlib_2_0_0
MAINTAINER= bacon4000@gmail.com
COMMENT= Neuroimaging Informatics Technology Initiative data format
-# LICENSE= public domain
+LICENSE= PD
USES= gmake
@@ -17,7 +18,7 @@ USES= gmake
# nifti bins by itself.
CONFLICTS= afni-[0-9]* dbh-[0-9]*
-MAKE_JOBS_UNSAFE= yes
+CFLAGS+= -fPIC
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/bin/* ${STAGEDIR}${PREFIX}/bin
diff --git a/science/nifticlib/files/patch-Makefile b/science/nifticlib/files/patch-Makefile
index 3416db34fd54..8a3134ae00bc 100644
--- a/science/nifticlib/files/patch-Makefile
+++ b/science/nifticlib/files/patch-Makefile
@@ -1,6 +1,6 @@
---- Makefile.orig 2010-07-20 19:18:58.000000000 +0200
-+++ Makefile 2014-02-20 23:32:52.000000000 +0100
-@@ -17,21 +17,21 @@
+--- Makefile.orig 2010-07-20 17:18:58 UTC
++++ Makefile
+@@ -17,21 +17,21 @@ TARFILE_NAME = nifticlib-2.0.0
## Compiler defines
@@ -17,7 +17,7 @@
+AR ?= ar
+RANLIB ?= ranlib
+DEPENDFLAGS ?= -MM
-+GNU_ANSI_FLAGS ?= -Wall -ansi -pedantic
++GNU_ANSI_FLAGS ?= -ansi -pedantic
+ANSI_FLAGS += ${GNU_ANSI_FLAGS}
+CFLAGS += $(ANSI_FLAGS)
@@ -34,7 +34,7 @@
## Installation
-@@ -41,9 +41,9 @@
+@@ -41,9 +41,9 @@ INSTALL_INC_DIR = include
## Zlib defines
@@ -47,7 +47,7 @@
##############################################################
# platform specific redefines (to use, set ARCH appropriately)
-@@ -116,33 +116,33 @@
+@@ -116,33 +116,33 @@ clean_all: clean regress_clean_all insta
znz:
echo "arch is $(ARCH)"
@@ -87,7 +87,7 @@
@echo Utility programs built.
@echo ""
-@@ -152,7 +152,7 @@
+@@ -152,7 +152,7 @@ doc:
@echo ""
regress_data:
@@ -96,7 +96,7 @@
@echo ""
@echo Regression testing data installed.
@echo See Testing/README_regress for details.
-@@ -167,25 +167,25 @@
+@@ -167,25 +167,25 @@ $(INSTALL_INC_DIR):
$(INSTALL_LIB_DIR):
mkdir -p $@
@@ -126,7 +126,7 @@
($(CP) $(FSLIO)/*.a $(INSTALL_LIB_DIR); $(CP) $(FSLIO)/*.h $(INSTALL_INC_DIR);)
$(RANLIB) $(INSTALL_LIB_DIR)/*.a
@echo " $(FSLIO) installed."
-@@ -212,19 +212,19 @@
+@@ -212,19 +212,19 @@ fslio_clean:
(cd $(FSLIO); $(RM) -f *.o *.a core; $(RM) -f depend.mk;)
examples_clean:
diff --git a/science/nifticlib/files/patch-examples-Makefile b/science/nifticlib/files/patch-examples-Makefile
index a60095c0de11..4f85e5b8decf 100644
--- a/science/nifticlib/files/patch-examples-Makefile
+++ b/science/nifticlib/files/patch-examples-Makefile
@@ -1,5 +1,5 @@
---- examples/Makefile.orig 2013-10-29 15:56:43.000000000 -0500
-+++ examples/Makefile 2013-10-29 15:56:48.000000000 -0500
+--- examples/Makefile.orig 2009-04-14 14:47:16 UTC
++++ examples/Makefile
@@ -1,4 +1,4 @@
-CC = gcc
+CC ?= gcc
diff --git a/science/nifticlib/files/patch-utils-Makefile b/science/nifticlib/files/patch-utils-Makefile
index 49ca2d28e4d5..d8177559df29 100644
--- a/science/nifticlib/files/patch-utils-Makefile
+++ b/science/nifticlib/files/patch-utils-Makefile
@@ -1,5 +1,5 @@
---- utils/Makefile.orig 2007-05-17 15:18:44.000000000 -0500
-+++ utils/Makefile 2013-10-29 15:55:12.000000000 -0500
+--- utils/Makefile.orig 2007-05-17 20:18:44 UTC
++++ utils/Makefile
@@ -1,5 +1,5 @@
-CC = gcc
-CFLAGS = -ansi -pedantic