aboutsummaryrefslogtreecommitdiff
path: root/science/opsin
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2019-02-14 00:54:56 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2019-02-14 00:54:56 +0000
commit88cd303725096e7fb267e1a1c96613c2c6ebcf09 (patch)
treeee3073abc63ff6af8c19a302788e3d93d78073e7 /science/opsin
parente3f5646b83360051abd99ec907599b2dc3e3fc20 (diff)
downloadports-88cd303725096e7fb267e1a1c96613c2c6ebcf09.tar.gz
ports-88cd303725096e7fb267e1a1c96613c2c6ebcf09.zip
New port: science/opsin: Open Parser for Systematic IUPAC Nomenclature of chemical names
Notes
Notes: svn path=/head/; revision=492893
Diffstat (limited to 'science/opsin')
-rw-r--r--science/opsin/Makefile62
-rw-r--r--science/opsin/distinfo5
-rw-r--r--science/opsin/files/opsin.in5
-rw-r--r--science/opsin/pkg-descr6
4 files changed, 78 insertions, 0 deletions
diff --git a/science/opsin/Makefile b/science/opsin/Makefile
new file mode 100644
index 000000000000..79a4c857bb2a
--- /dev/null
+++ b/science/opsin/Makefile
@@ -0,0 +1,62 @@
+# $FreeBSD$
+
+PORTNAME= opsin
+DISTVERSION= 3.0.20190208
+CATEGORIES= science java
+MASTER_SITES= https://bitbucket.org/${BB_ACCOUNT}/${PORTNAME}/get/${BB_COMMIT}${EXTRACT_SUFX}?dummy=/:src
+DISTFILES= ${PORTNAME}-${DISTVERSION}${EXTRACT_SUFX}:src
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Open Parser for Systematic IUPAC Nomenclature of chemical names
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE.txt
+
+BUILD_DEPENDS= mvn:devel/maven
+
+USE_JAVA= yes
+
+NO_ARCH= yes
+
+BB_ACCOUNT= dan2097
+BB_COMMIT= 6688e0cedfcc
+
+WRKSRC= ${WRKDIR}/${BB_ACCOUNT}-${PORTNAME}-${BB_COMMIT}
+SUB_FILES= ${PORTNAME}
+SUB_LIST= JAVA=${JAVA} PORTNAME=${PORTNAME} PORTVERSION=${PORTVERSION}
+
+PLIST_FILES= bin/${PORTNAME} \
+ ${JAVAJARDIR}/${PORTNAME}-${PORTVERSION}-jar-with-dependencies.jar
+
+# to rebuild the deps archive:
+# 1. set DEV_UPDATE_MODE=yes
+# 2. make makesum build
+# 3. upload the *-deps archive
+# 4. set DEV_UPDATE_MODE=no
+# 5. make clean makesum
+
+DEV_UPDATE_MODE= no
+
+.if (${DEV_UPDATE_MODE} == "yes")
+post-build:
+ @cd ${WRKDIR} && ${TAR} czf ${DISTDIR}/${PORTNAME}-${DISTVERSION}-deps${EXTRACT_SUFX} .m2
+ @${ECHO} "(!!!) Please upload the maven deps archive: ${DISTDIR}/${PORTNAME}-${DISTVERSION}-deps${EXTRACT_SUFX}"
+.else
+MASTER_SITES+= LOCAL/yuri/:maven
+DISTFILES+= ${PORTNAME}-${DISTVERSION}-deps${EXTRACT_SUFX}:maven
+MVN_ARGS= --offline
+.endif
+
+do-build:
+ @cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} \
+ ${LOCALBASE}/bin/mvn ${MVN_ARGS} \
+ -fae install \
+ -Dmaven.test.skip=true \
+ -Duser.home=${WRKDIR} \
+ package assembly:assembly
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKDIR}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_DATA} ${WRKSRC}/target/${PORTNAME}-*-jar-with-dependencies.jar ${STAGEDIR}${JAVAJARDIR}/${PORTNAME}-${PORTVERSION}-jar-with-dependencies.jar
+
+.include <bsd.port.mk>
diff --git a/science/opsin/distinfo b/science/opsin/distinfo
new file mode 100644
index 000000000000..129888a12b23
--- /dev/null
+++ b/science/opsin/distinfo
@@ -0,0 +1,5 @@
+TIMESTAMP = 1550104217
+SHA256 (opsin-3.0.20190208.tar.gz) = d37222168a0ffb412109095212152f31b0b909abdaa14158561424651426df8f
+SIZE (opsin-3.0.20190208.tar.gz) = 1795278
+SHA256 (opsin-3.0.20190208-deps.tar.gz) = b42bfc011571d7e12fbc4e051653d19edaef6b7d04aaa146c817e1309dc4cba2
+SIZE (opsin-3.0.20190208-deps.tar.gz) = 20394666
diff --git a/science/opsin/files/opsin.in b/science/opsin/files/opsin.in
new file mode 100644
index 000000000000..18c1f4238265
--- /dev/null
+++ b/science/opsin/files/opsin.in
@@ -0,0 +1,5 @@
+#!/bin/sh
+
+export LC_ALL=en_US.UTF-8
+
+%%JAVA%% -jar %%JAVAJARDIR%%/%%PORTNAME%%-%%PORTVERSION%%-jar-with-dependencies.jar "$@"
diff --git a/science/opsin/pkg-descr b/science/opsin/pkg-descr
new file mode 100644
index 000000000000..24ddb2751426
--- /dev/null
+++ b/science/opsin/pkg-descr
@@ -0,0 +1,6 @@
+OPSIN is a Java library for IUPAC name-to-structure conversion offering high
+recall and precision on organic chemical nomenclature.
+Supported outputs are SMILES, CML (Chemical Markup Language) and InChI (IUPAC
+International Chemical Identifier).
+
+WWW: https://bitbucket.org/dan2097/opsin/src/default/