aboutsummaryrefslogtreecommitdiff
path: root/science/orthanc-dicomweb
diff options
context:
space:
mode:
authorFrank Scholl <maintainer.freebsd@xpoundit.com>2021-08-09 08:26:41 +0000
committerGuangyuan Yang <ygy@FreeBSD.org>2021-08-09 08:26:41 +0000
commit27ff93b979893807537870b43d7c376e531d5a0a (patch)
treec76ea6ef916dc3d55cfc17edf10aa9d1794348b1 /science/orthanc-dicomweb
parent69fef1a5a4417da990c81910f78c5055f0ca0b28 (diff)
downloadports-27ff93b979893807537870b43d7c376e531d5a0a.tar.gz
ports-27ff93b979893807537870b43d7c376e531d5a0a.zip
science/orthanc-dicomweb: Revive port
Plugin to bring support of the DICOMweb standard into Orthanc. PR: 242547 Reviewed by: lwhsu
Diffstat (limited to 'science/orthanc-dicomweb')
-rw-r--r--science/orthanc-dicomweb/Makefile62
-rw-r--r--science/orthanc-dicomweb/distinfo19
-rw-r--r--science/orthanc-dicomweb/pkg-descr12
-rw-r--r--science/orthanc-dicomweb/pkg-plist2
4 files changed, 95 insertions, 0 deletions
diff --git a/science/orthanc-dicomweb/Makefile b/science/orthanc-dicomweb/Makefile
new file mode 100644
index 000000000000..6d0e3669e0c2
--- /dev/null
+++ b/science/orthanc-dicomweb/Makefile
@@ -0,0 +1,62 @@
+# Created by: maintainer.freebsd@xpoundit.com
+
+PORTNAME= orthanc-dicomweb
+DISTVERSION= 1.6
+CATEGORIES= science
+MASTER_SITES= https://www.orthanc-server.com/downloads/get.php?path=/plugin-dicom-web/:main \
+ https://www.orthanc-server.com/downloads/get.php?path=/orthanc/:framework \
+ https://orthanc.osimis.io/ThirdPartyDownloads/:thirdparty \
+ https://orthanc.osimis.io/ThirdPartyDownloads/dicom-web/:thirdpartydicomweb
+DISTFILES= OrthancDicomWeb-${PORTVERSION}.tar.gz:main
+EXTRADISTFILES= Orthanc-1.9.3.tar.gz:framework \
+ e2fsprogs-1.44.5.tar.gz:thirdparty \
+ bootstrap-4.3.1.zip:thirdpartydicomweb \
+ vuejs-2.6.10.tar.gz:thirdpartydicomweb \
+ axios-0.19.0.tar.gz:thirdpartydicomweb \
+ Font-Awesome-4.7.0.tar.gz:thirdpartydicomweb \
+ bootstrap-vue-2.0.0-rc.24-dist.tar.gz:thirdpartydicomweb \
+ babel-polyfill-6.26.0.min.js.gz:thirdpartydicomweb
+DISTFILES+= ${EXTRADISTFILES}
+DIST_SUBDIR= orthanc
+EXTRACT_ONLY= OrthancDicomWeb-${PORTVERSION}.tar.gz
+
+MAINTAINER= maintainer.freebsd@xpoundit.com
+COMMENT= Orthanc plugin to bring support of the DICOMweb standard into Orthanc
+
+LICENSE= AGPLv3
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+BUILD_DEPENDS= ${LOCALBASE}/include/orthanc/OrthancCPlugin.h:science/orthanc
+LIB_DEPENDS= libboost_atomic.so:devel/boost-libs \
+ libexpat.so:textproc/expat2 \
+ libgdcmCommon.so:devel/gdcm \
+ libicudata.so:devel/icu \
+ libjsoncpp.so:devel/jsoncpp \
+ libopenjp2.so:graphics/openjpeg \
+ libpugixml.so:textproc/pugixml
+RUN_DEPENDS= Orthanc:science/orthanc
+
+USES= cmake localbase python:build
+USE_LDCONFIG= yes
+
+WRKSRC= ${WRKDIR}/OrthancDicomWeb-${PORTVERSION}
+
+CMAKE_OFF= USE_SYSTEM_UUID
+CMAKE_ARGS= -DORTHANC_FRAMEWORK_ROOT=${WRKSRC}/ThirdPartyDownloads/Orthanc-1.9.3/OrthancFramework/Sources \
+ -DORTHANC_FRAMEWORK_SOURCE=path
+CFLAGS+= -DORTHANC_ENABLE_LOGGING_PLUGIN -DNDEBUG
+CXXFLAGS+= -DNDEBUG
+
+PLIST_SUB= DISTVERSION=${DISTVERSION}
+
+post-extract:
+ ${MKDIR} ${WRKSRC}/ThirdPartyDownloads
+.for f in ${EXTRADISTFILES:C/:[^:]*//}
+ ${CP} ${DISTDIR}/${DIST_SUBDIR}/${f} ${WRKSRC}/ThirdPartyDownloads
+.endfor
+ ${TAR} -C ${WRKSRC}/ThirdPartyDownloads -xf ${WRKSRC}/ThirdPartyDownloads/Orthanc-1.9.3.tar.gz
+
+do-test:
+ @cd ${BUILD_WRKSRC} && ./UnitTests
+
+.include <bsd.port.mk>
diff --git a/science/orthanc-dicomweb/distinfo b/science/orthanc-dicomweb/distinfo
new file mode 100644
index 000000000000..96c67bc641c5
--- /dev/null
+++ b/science/orthanc-dicomweb/distinfo
@@ -0,0 +1,19 @@
+TIMESTAMP = 1620903521
+SHA256 (orthanc/OrthancDicomWeb-1.6.tar.gz) = 4e5df573d6000c2707999222420efa7fcb62bea0b4f62369ffaa0277c5be8cd6
+SIZE (orthanc/OrthancDicomWeb-1.6.tar.gz) = 202325
+SHA256 (orthanc/Orthanc-1.9.3.tar.gz) = 41cc35a3d15ecb0d7b834e8e28a740cc4ffa1f333c019a764228d60e96608960
+SIZE (orthanc/Orthanc-1.9.3.tar.gz) = 1818313
+SHA256 (orthanc/e2fsprogs-1.44.5.tar.gz) = 2e211fae27ef74d5af4a4e40b10b8df7f87c655933bd171aab4889bfc4e6d1cc
+SIZE (orthanc/e2fsprogs-1.44.5.tar.gz) = 7619237
+SHA256 (orthanc/bootstrap-4.3.1.zip) = c7fcae50c070250e4e1ae36a670e5ee8fe9d529eb3f1a03c527f8223ce3f61bc
+SIZE (orthanc/bootstrap-4.3.1.zip) = 2705432
+SHA256 (orthanc/vuejs-2.6.10.tar.gz) = e3d900cd9266b5bed9bb6d575fc9ab6787e79e7ad21c01ee1277bff5453121f2
+SIZE (orthanc/vuejs-2.6.10.tar.gz) = 1576461
+SHA256 (orthanc/axios-0.19.0.tar.gz) = 29577c6085b090b4e4a99392fcdd582fb6bbcb49b2aaf2cc7b7fa3874529b380
+SIZE (orthanc/axios-0.19.0.tar.gz) = 125193
+SHA256 (orthanc/Font-Awesome-4.7.0.tar.gz) = de512ba0e1dead382bbfce372cde74b3f18971d876fffb635ee9333f0db05d43
+SIZE (orthanc/Font-Awesome-4.7.0.tar.gz) = 2672776
+SHA256 (orthanc/bootstrap-vue-2.0.0-rc.24-dist.tar.gz) = bc62cc91c2c3c24ddd29321d91be629e72db6129413ab6b8111ce13c2a57775b
+SIZE (orthanc/bootstrap-vue-2.0.0-rc.24-dist.tar.gz) = 2448005
+SHA256 (orthanc/babel-polyfill-6.26.0.min.js.gz) = 087d3d2d6212afb418f50491858f7f055cb54defb6351d6c5d008f662a2a95c2
+SIZE (orthanc/babel-polyfill-6.26.0.min.js.gz) = 34718
diff --git a/science/orthanc-dicomweb/pkg-descr b/science/orthanc-dicomweb/pkg-descr
new file mode 100644
index 000000000000..5c0bc7960f51
--- /dev/null
+++ b/science/orthanc-dicomweb/pkg-descr
@@ -0,0 +1,12 @@
+Orthanc-dicomweb extends the native REST API of Orthanc with a reference
+implementation of the DICOMweb standard. Loading the plugin into Orthanc will
+provide support of WADO-URI (previously known simply as WADO), WADO-RS,
+QIDO-RS and STOW-RS.
+
+Out-of-the-box, Orthanc comes with its own REST API. This API allows full
+CRUD operations (create, read, update and delete) on the set of DICOM
+resources that Orthanc stores, together with commands that trigger calls to
+the DICOM protocol (C-Echo SCU/SCP, C-Store SCU/SCP, C-Find SCU/SCP, C-Move
+SCU/SCP).
+
+WWW: https://www.orthanc-server.com/static.php?page=dicomweb
diff --git a/science/orthanc-dicomweb/pkg-plist b/science/orthanc-dicomweb/pkg-plist
new file mode 100644
index 000000000000..a192da83bb5e
--- /dev/null
+++ b/science/orthanc-dicomweb/pkg-plist
@@ -0,0 +1,2 @@
+share/orthanc/plugins/libOrthancDicomWeb.so
+share/orthanc/plugins/libOrthancDicomWeb.so.%%DISTVERSION%%