aboutsummaryrefslogtreecommitdiff
path: root/science/p5-Chemistry-File-MDLMol
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2010-04-02 15:34:39 +0000
committerMartin Wilke <miwi@FreeBSD.org>2010-04-02 15:34:39 +0000
commit4af115e4ea20b1f53a8b031d031876bc65b98199 (patch)
tree406738807aeeddc8eee16fa13af12a972ffea317 /science/p5-Chemistry-File-MDLMol
parent4eb372dfc75f762854e68a54289c6fccf8296260 (diff)
downloadports-4af115e4ea20b1f53a8b031d031876bc65b98199.tar.gz
ports-4af115e4ea20b1f53a8b031d031876bc65b98199.zip
Perl module which will parse a SMARTS (SMiles ARbitrary Target Specification)
string, generating a Chemistry::Pattern object. It is a file I/O driver for the PerlMol toolkit. WWW: http://search.cpan.org/dist/Chemistry-File-SMARTS/ PR: ports/145143 Submitted by: Steve Wills <steve at mouf.net>
Notes
Notes: svn path=/head/; revision=252057
Diffstat (limited to 'science/p5-Chemistry-File-MDLMol')
-rw-r--r--science/p5-Chemistry-File-MDLMol/Makefile27
-rw-r--r--science/p5-Chemistry-File-MDLMol/distinfo3
-rw-r--r--science/p5-Chemistry-File-MDLMol/pkg-descr5
-rw-r--r--science/p5-Chemistry-File-MDLMol/pkg-plist6
4 files changed, 41 insertions, 0 deletions
diff --git a/science/p5-Chemistry-File-MDLMol/Makefile b/science/p5-Chemistry-File-MDLMol/Makefile
new file mode 100644
index 000000000000..c77ffa60b554
--- /dev/null
+++ b/science/p5-Chemistry-File-MDLMol/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: p5-Chemistry-File-MDLMol
+# Date created: 2010-03-10
+# Whom: Steve Wills <steve@mouf.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Chemistry-File-MDLMol
+PORTVERSION= 0.21
+CATEGORIES= science perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= ../../authors/id/I/IT/ITUB
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= steve@mouf.net
+COMMENT= MDL molfile reader/write
+
+BUILD_DEPENDS= ${SITE_PERL}/Chemistry/Mol.pm:${PORTSDIR}/science/p5-Chemistry-Mol \
+ ${SITE_PERL}/Chemistry/Ring/Find.pm:${PORTSDIR}/science/p5-Chemistry-Ring
+RUN_DEPENDS= ${SITE_PERL}/Chemistry/Mol.pm:${PORTSDIR}/science/p5-Chemistry-Mol \
+ ${SITE_PERL}/Chemistry/Ring/Find.pm:${PORTSDIR}/science/p5-Chemistry-Ring
+
+MAN3= Chemistry::File::MDLMol.3 Chemistry::File::SDF.3
+
+PERL_CONFIGURE= yes
+
+.include <bsd.port.mk>
diff --git a/science/p5-Chemistry-File-MDLMol/distinfo b/science/p5-Chemistry-File-MDLMol/distinfo
new file mode 100644
index 000000000000..cf9ace007fb1
--- /dev/null
+++ b/science/p5-Chemistry-File-MDLMol/distinfo
@@ -0,0 +1,3 @@
+MD5 (Chemistry-File-MDLMol-0.21.tar.gz) = 60c3dc04da33282fa5234d5f59ae73bc
+SHA256 (Chemistry-File-MDLMol-0.21.tar.gz) = 5a57cb1c01bacfed1e54749d18d924c9331ec283da240845175fa41b65edd44c
+SIZE (Chemistry-File-MDLMol-0.21.tar.gz) = 14830
diff --git a/science/p5-Chemistry-File-MDLMol/pkg-descr b/science/p5-Chemistry-File-MDLMol/pkg-descr
new file mode 100644
index 000000000000..702f843dbd87
--- /dev/null
+++ b/science/p5-Chemistry-File-MDLMol/pkg-descr
@@ -0,0 +1,5 @@
+Perl module which will parse a SMARTS (SMiles ARbitrary Target Specification)
+string, generating a Chemistry::Pattern object. It is a file I/O driver for
+the PerlMol toolkit.
+
+WWW: http://search.cpan.org/dist/Chemistry-File-SMARTS/
diff --git a/science/p5-Chemistry-File-MDLMol/pkg-plist b/science/p5-Chemistry-File-MDLMol/pkg-plist
new file mode 100644
index 000000000000..6a4e888825f6
--- /dev/null
+++ b/science/p5-Chemistry-File-MDLMol/pkg-plist
@@ -0,0 +1,6 @@
+%%SITE_PERL%%/mach/auto/Chemistry/File/MDLMol/.packlist
+%%SITE_PERL%%/Chemistry/File/MDLMol.pm
+%%SITE_PERL%%/Chemistry/File/SDF.pm
+@dirrmtry %%SITE_PERL%%/mach/auto/Chemistry/File/MDLMol
+@dirrmtry %%SITE_PERL%%/mach/auto/Chemistry/File
+@dirrmtry %%SITE_PERL%%/mach/auto/Chemistry