aboutsummaryrefslogtreecommitdiff
path: root/science/p5-Chemistry-Mol
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2009-05-16 23:29:15 +0000
committerMartin Wilke <miwi@FreeBSD.org>2009-05-16 23:29:15 +0000
commit275fec265cb1116775cf134e1a2585a8664b7379 (patch)
treedac355f6970d831b30474b470b59a43ff8176f98 /science/p5-Chemistry-Mol
parent2fa5da93a63781175913269642310291709fbe6e (diff)
downloadports-275fec265cb1116775cf134e1a2585a8664b7379.tar.gz
ports-275fec265cb1116775cf134e1a2585a8664b7379.zip
Chemistr-Mol is a toolkit includes basic objects and methods to
describe molecules. It consists of several modules: Chemistry::Mol, Chemistry::Atom, Chemistry::Bond, and Chemistry::File. WWW: http://search.cpan.org/dist/Chemistry-Mol/ PR: ports/134462 Submitted by: Wen Heping <wenheping at gmail.com>
Notes
Notes: svn path=/head/; revision=234042
Diffstat (limited to 'science/p5-Chemistry-Mol')
-rw-r--r--science/p5-Chemistry-Mol/Makefile27
-rw-r--r--science/p5-Chemistry-Mol/distinfo3
-rw-r--r--science/p5-Chemistry-Mol/pkg-descr8
-rw-r--r--science/p5-Chemistry-Mol/pkg-plist13
4 files changed, 51 insertions, 0 deletions
diff --git a/science/p5-Chemistry-Mol/Makefile b/science/p5-Chemistry-Mol/Makefile
new file mode 100644
index 000000000000..4290b353aff5
--- /dev/null
+++ b/science/p5-Chemistry-Mol/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: Chemistry-Mol
+# Date created: 11 May, 2009
+# Whom: Wen Heping <wenheping@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Chemistry-Mol
+PORTVERSION= 0.37
+CATEGORIES= science perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= wenheping@gmail.com
+COMMENT= Perl toolkit to describe molecules
+
+BUILD_DEPENDS= p5-Math-VectorReal>=1.02:${PORTSDIR}/math/p5-Math-VectorReal
+RUN_DEPENDS= p5-Math-VectorReal>=1.02:${PORTSDIR}/math/p5-Math-VectorReal
+
+PERL_CONFIGURE= yes
+
+MAN3= Chemistry::Atom.3 Chemistry::Bond.3 \
+ Chemistry::Obj.3 Chemistry::File.3 \
+ Chemistry::Tutorial.3 Chemistry::File::Dumper.3 \
+ Chemistry::Mol.3 Chemistry::File::Formula.3
+
+.include <bsd.port.mk>
diff --git a/science/p5-Chemistry-Mol/distinfo b/science/p5-Chemistry-Mol/distinfo
new file mode 100644
index 000000000000..88bb4507940e
--- /dev/null
+++ b/science/p5-Chemistry-Mol/distinfo
@@ -0,0 +1,3 @@
+MD5 (Chemistry-Mol-0.37.tar.gz) = b3826c67e866a99169f3cfec1205642a
+SHA256 (Chemistry-Mol-0.37.tar.gz) = 35cb720f4709c3693ec88ffa3b5f9dd870c3161a3498c08f80d77683b7188846
+SIZE (Chemistry-Mol-0.37.tar.gz) = 44222
diff --git a/science/p5-Chemistry-Mol/pkg-descr b/science/p5-Chemistry-Mol/pkg-descr
new file mode 100644
index 000000000000..f45fa829bc73
--- /dev/null
+++ b/science/p5-Chemistry-Mol/pkg-descr
@@ -0,0 +1,8 @@
+Chemistr-Mol is a toolkit includes basic objects and methods to
+describe molecules. It consists of several modules: Chemistry::Mol,
+Chemistry::Atom, Chemistry::Bond, and Chemistry::File.
+
+They are the core modules of the PerlMol toolkit, see:
+http://www.perlmol.org/.
+
+WWW: http://search.cpan.org/dist/Chemistry-Mol/
diff --git a/science/p5-Chemistry-Mol/pkg-plist b/science/p5-Chemistry-Mol/pkg-plist
new file mode 100644
index 000000000000..c0fb8d539f97
--- /dev/null
+++ b/science/p5-Chemistry-Mol/pkg-plist
@@ -0,0 +1,13 @@
+%%SITE_PERL%%/Chemistry/Atom.pm
+%%SITE_PERL%%/Chemistry/Bond.pm
+%%SITE_PERL%%/Chemistry/Obj.pm
+%%SITE_PERL%%/Chemistry/File.pm
+%%SITE_PERL%%/Chemistry/Tutorial.pod
+%%SITE_PERL%%/Chemistry/Mol.pm
+%%SITE_PERL%%/Chemistry/File/Dumper.pm
+%%SITE_PERL%%/Chemistry/File/Formula.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Chemistry/Mol/.packlist
+@dirrm %%SITE_PERL%%/Chemistry/File
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Chemistry/Mol
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Chemistry
+@dirrmtry %%SITE_PERL%%/Chemistry