aboutsummaryrefslogtreecommitdiff
path: root/science/p5-Chemistry-Pattern
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2010-04-02 15:25:56 +0000
committerMartin Wilke <miwi@FreeBSD.org>2010-04-02 15:25:56 +0000
commitbe4a09a2d8f4e5579dd1ecca877cfa730a1ae06c (patch)
treef78a6cd5c3eeae61cdda19e76af0b1addcd40073 /science/p5-Chemistry-Pattern
parentb9c5628b0dfc9ce9a87c582dcc17488585174029 (diff)
downloadports-be4a09a2d8f4e5579dd1ecca877cfa730a1ae06c.tar.gz
ports-be4a09a2d8f4e5579dd1ecca877cfa730a1ae06c.zip
Perl module which implements basic pattern matching for molecules.
WWW: http://search.cpan.org/dist/Chemistry-Pattern/ PR: ports/145143 Submitted by: Steve Wills <steve at mouf.net>
Notes
Notes: svn path=/head/; revision=252044
Diffstat (limited to 'science/p5-Chemistry-Pattern')
-rw-r--r--science/p5-Chemistry-Pattern/Makefile25
-rw-r--r--science/p5-Chemistry-Pattern/distinfo3
-rw-r--r--science/p5-Chemistry-Pattern/pkg-descr3
-rw-r--r--science/p5-Chemistry-Pattern/pkg-plist7
4 files changed, 38 insertions, 0 deletions
diff --git a/science/p5-Chemistry-Pattern/Makefile b/science/p5-Chemistry-Pattern/Makefile
new file mode 100644
index 000000000000..f32c5083a08a
--- /dev/null
+++ b/science/p5-Chemistry-Pattern/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: p5-Chemistry-Pattern
+# Date created: 2010-03-10
+# Whom: Steve Wills <steve@mouf.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Chemistry-Pattern
+PORTVERSION= 0.27
+CATEGORIES= science perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= ../../authors/id/I/IT/ITUB
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= steve@mouf.net
+COMMENT= Chemical substructure pattern matching
+
+BUILD_DEPENDS= ${SITE_PERL}/Chemistry/Mol.pm:${PORTSDIR}/science/p5-Chemistry-Mol
+RUN_DEPENDS= ${SITE_PERL}/Chemistry/Mol.pm:${PORTSDIR}/science/p5-Chemistry-Mol
+
+MAN3= Chemistry::Pattern.3 Chemistry::Pattern::Atom.3 Chemistry::Pattern::Bond.3
+
+PERL_CONFIGURE= yes
+
+.include <bsd.port.mk>
diff --git a/science/p5-Chemistry-Pattern/distinfo b/science/p5-Chemistry-Pattern/distinfo
new file mode 100644
index 000000000000..ea9682afe3da
--- /dev/null
+++ b/science/p5-Chemistry-Pattern/distinfo
@@ -0,0 +1,3 @@
+MD5 (Chemistry-Pattern-0.27.tar.gz) = 78b048d08f38fe920bdee57112c18c2d
+SHA256 (Chemistry-Pattern-0.27.tar.gz) = 4616612523cf2318cb79c27315d5a3030c9c860c5df169035092cf297cc504af
+SIZE (Chemistry-Pattern-0.27.tar.gz) = 8060
diff --git a/science/p5-Chemistry-Pattern/pkg-descr b/science/p5-Chemistry-Pattern/pkg-descr
new file mode 100644
index 000000000000..abdf9ad02a5f
--- /dev/null
+++ b/science/p5-Chemistry-Pattern/pkg-descr
@@ -0,0 +1,3 @@
+Perl module which implements basic pattern matching for molecules.
+
+WWW: http://search.cpan.org/dist/Chemistry-Pattern/
diff --git a/science/p5-Chemistry-Pattern/pkg-plist b/science/p5-Chemistry-Pattern/pkg-plist
new file mode 100644
index 000000000000..e76780fe37a7
--- /dev/null
+++ b/science/p5-Chemistry-Pattern/pkg-plist
@@ -0,0 +1,7 @@
+%%SITE_PERL%%/Chemistry/Pattern/Atom.pm
+%%SITE_PERL%%/Chemistry/Pattern/Bond.pm
+%%SITE_PERL%%/Chemistry/Pattern.pm
+%%SITE_PERL%%/mach/auto/Chemistry/Pattern/.packlist
+@dirrmtry %%SITE_PERL%%/mach/auto/Chemistry/Pattern
+@dirrmtry %%SITE_PERL%%/Chemistry/Pattern
+@dirrmtry %%SITE_PERL%%/Chemistry