aboutsummaryrefslogtreecommitdiff
path: root/science/p5-Geo-WebService-Elevation-USGS
diff options
context:
space:
mode:
authorWen Heping <wen@FreeBSD.org>2010-01-15 07:20:43 +0000
committerWen Heping <wen@FreeBSD.org>2010-01-15 07:20:43 +0000
commitdd998fd1cbc72e536ff674ebee6c67aa5fbd6b2d (patch)
treed3057e1f57e5d740ccbc0799c343ba7b64631f4e /science/p5-Geo-WebService-Elevation-USGS
parenta333b1db12f90695f4bed2dd0d7b72aea59428f3 (diff)
downloadports-dd998fd1cbc72e536ff674ebee6c67aa5fbd6b2d.tar.gz
ports-dd998fd1cbc72e536ff674ebee6c67aa5fbd6b2d.zip
Geo::WebService::Elevation::USGS executes elevation queries against the
United States Geological Survey's web server. You provide the latitude and longitude in degrees, with south latitude and west longitude being negative. The return is typically a hash containing the data you want. Query errors are exceptions by default, though the object can be configured to signal an error by an undef response, with the error retrievable from the 'error' attribute. WWW: http://search.cpan.org/dist/Geo-WebService-Elevation-USGS/
Notes
Notes: svn path=/head/; revision=247922
Diffstat (limited to 'science/p5-Geo-WebService-Elevation-USGS')
-rw-r--r--science/p5-Geo-WebService-Elevation-USGS/Makefile25
-rw-r--r--science/p5-Geo-WebService-Elevation-USGS/distinfo3
-rw-r--r--science/p5-Geo-WebService-Elevation-USGS/pkg-descr9
-rw-r--r--science/p5-Geo-WebService-Elevation-USGS/pkg-plist9
4 files changed, 46 insertions, 0 deletions
diff --git a/science/p5-Geo-WebService-Elevation-USGS/Makefile b/science/p5-Geo-WebService-Elevation-USGS/Makefile
new file mode 100644
index 000000000000..7e0bbdffcb44
--- /dev/null
+++ b/science/p5-Geo-WebService-Elevation-USGS/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: p5-Geo-WebService-Elevation-USGS
+# Date created: 15 Jan, 2010
+# Whom: Wen Heping <wen@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Geo-WebService-Elevation-USGS
+PORTVERSION= 0.005
+CATEGORIES= science perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= wen@FreeBSD.org
+COMMENT= Perl extension for elevation queries against USGS web services
+
+BUILD_DEPENDS= p5-SOAP-Lite>=0:${PORTSDIR}/net/p5-SOAP-Lite \
+ p5-Params-Util>=0.11:${PORTSDIR}/devel/p5-Params-Util
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Geo::WebService::Elevation::USGS.3
+
+.include <bsd.port.mk>
diff --git a/science/p5-Geo-WebService-Elevation-USGS/distinfo b/science/p5-Geo-WebService-Elevation-USGS/distinfo
new file mode 100644
index 000000000000..5cf46e397454
--- /dev/null
+++ b/science/p5-Geo-WebService-Elevation-USGS/distinfo
@@ -0,0 +1,3 @@
+MD5 (Geo-WebService-Elevation-USGS-0.005.tar.gz) = 79c17e624cb68ba8a768511e3b2b53ce
+SHA256 (Geo-WebService-Elevation-USGS-0.005.tar.gz) = 5be123a962dc0f6159433dc3d51aa8af9eb54786dafd249a6282c7db083b3bd9
+SIZE (Geo-WebService-Elevation-USGS-0.005.tar.gz) = 30637
diff --git a/science/p5-Geo-WebService-Elevation-USGS/pkg-descr b/science/p5-Geo-WebService-Elevation-USGS/pkg-descr
new file mode 100644
index 000000000000..96584aa33032
--- /dev/null
+++ b/science/p5-Geo-WebService-Elevation-USGS/pkg-descr
@@ -0,0 +1,9 @@
+Geo::WebService::Elevation::USGS executes elevation queries against the
+United States Geological Survey's web server. You provide the latitude
+and longitude in degrees, with south latitude and west longitude being
+negative. The return is typically a hash containing the data you want.
+Query errors are exceptions by default, though the object can be configured
+to signal an error by an undef response, with the error retrievable from
+the 'error' attribute.
+
+WWW: http://search.cpan.org/dist/Geo-WebService-Elevation-USGS/
diff --git a/science/p5-Geo-WebService-Elevation-USGS/pkg-plist b/science/p5-Geo-WebService-Elevation-USGS/pkg-plist
new file mode 100644
index 000000000000..0de90d3f51d6
--- /dev/null
+++ b/science/p5-Geo-WebService-Elevation-USGS/pkg-plist
@@ -0,0 +1,9 @@
+%%SITE_PERL%%/Geo/WebService/Elevation/USGS.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Geo/WebService/Elevation/USGS/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Geo/WebService/Elevation/USGS
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Geo/WebService/Elevation
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Geo/WebService
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Geo
+@dirrmtry %%SITE_PERL%%/Geo/WebService/Elevation
+@dirrmtry %%SITE_PERL%%/Geo/WebService
+@dirrmtry %%SITE_PERL%%/Geo