aboutsummaryrefslogtreecommitdiff
path: root/science/p5-Physics-Unit/Makefile
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2014-02-06 14:10:06 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2014-02-06 14:10:06 +0000
commit5531049ac9ed8a81edbb9dbd35e3657b838fd2a6 (patch)
treee14afdd10c1405716a9a54919b49e51cde2fd580 /science/p5-Physics-Unit/Makefile
parent43c02d03578b3d164298e007af12dc8a6a00bc5c (diff)
Notes
Diffstat (limited to 'science/p5-Physics-Unit/Makefile')
-rw-r--r--science/p5-Physics-Unit/Makefile21
1 files changed, 8 insertions, 13 deletions
diff --git a/science/p5-Physics-Unit/Makefile b/science/p5-Physics-Unit/Makefile
index cc10c967c6a0..bd9c3f0d52b1 100644
--- a/science/p5-Physics-Unit/Makefile
+++ b/science/p5-Physics-Unit/Makefile
@@ -16,19 +16,14 @@ LICENSE_COMB= dual
USES= perl5
USE_PERL5= modbuild
-MAN1= physics-unit.1
-MAN3= Physics::Unit.3 \
- Physics::Unit::Implementation.3 \
- Physics::Unit::Scalar.3 \
- Physics::Unit::Scalar::Implementation.3 \
- Physics::Unit::UnitsByName.3 \
- Physics::Unit::UnitsByType.3
-
-NO_STAGE= yes
+OPTIONS_DEFINE= EXAMPLES
+
+PORTEXAMPLES= *
+
+.include <bsd.port.options.mk>
+
post-install:
-.if !defined(NOPORTEXAMPLES)
- ${MKDIR} ${EXAMPLESDIR}
- (cd ${WRKSRC}/eg/ && ${COPYTREE_SHARE} '*.pl' ${EXAMPLESDIR})
-.endif
+ ${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+ (cd ${WRKSRC}/eg/ && ${COPYTREE_SHARE} '*.pl' ${STAGEDIR}${EXAMPLESDIR})
.include <bsd.port.mk>