aboutsummaryrefslogtreecommitdiff
path: root/science/paraview
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2023-11-08 19:21:07 +0000
committerThierry Thomas <thierry@FreeBSD.org>2023-11-08 19:21:07 +0000
commit12ecc73c3ada18ea18d19af8e0aa8cc5bf7e1344 (patch)
tree9db5ca33f77ce7a58723da8fdf09633fab974740 /science/paraview
parent379cec2296b783715804b77e3366953a48b324f6 (diff)
downloadports-12ecc73c3ada18ea18d19af8e0aa8cc5bf7e1344.tar.gz
ports-12ecc73c3ada18ea18d19af8e0aa8cc5bf7e1344.zip
science/paraview: unbreak after the upgrade of OpenTURNS
Drop OPENTURNS_USE_FILE (patch d9bbc2c4 from Julien Schueller).
Diffstat (limited to 'science/paraview')
-rw-r--r--science/paraview/files/patch-VTK_Filters_OpenTURNS_CMakeLists.txt14
1 files changed, 14 insertions, 0 deletions
diff --git a/science/paraview/files/patch-VTK_Filters_OpenTURNS_CMakeLists.txt b/science/paraview/files/patch-VTK_Filters_OpenTURNS_CMakeLists.txt
new file mode 100644
index 000000000000..7ee48aac38c1
--- /dev/null
+++ b/science/paraview/files/patch-VTK_Filters_OpenTURNS_CMakeLists.txt
@@ -0,0 +1,14 @@
+--- VTK/Filters/OpenTURNS/CMakeLists.txt.orig 2023-09-22 14:35:37 UTC
++++ VTK/Filters/OpenTURNS/CMakeLists.txt
+@@ -1,6 +1,9 @@ find_package(OpenTURNS 1.8 REQUIRED)
+ find_package(OpenTURNS 1.8 REQUIRED)
+-# XXX(fixme)
+-include(${OPENTURNS_USE_FILE})
++
++if (EXISTS "${OPENTURNS_USE_FILE}")
++ # removed in 1.21
++ include (${OPENTURNS_USE_FILE})
++endif ()
+
+ set(classes
+ vtkOTDensityMap