aboutsummaryrefslogtreecommitdiff
path: root/science/paraview
diff options
context:
space:
mode:
authorBrooks Davis <brooks@FreeBSD.org>2023-12-11 17:42:03 +0000
committerBrooks Davis <brooks@FreeBSD.org>2023-12-11 17:42:27 +0000
commitb5f490feb62fa1d7f999e8b5a25ac21147dac3e2 (patch)
treee78e5dbecc788b6ff7892cc43758254e016c5c05 /science/paraview
parentf2348b342e632aa2974ec09ff067b3bcbd0a2f50 (diff)
downloadports-b5f490feb62fa1d7f999e8b5a25ac21147dac3e2.tar.gz
ports-b5f490feb62fa1d7f999e8b5a25ac21147dac3e2.zip
science/paraview: remove useless sbrk use
There was a single use in a debug statement so just remove it. Approved by: thierry (maintainer) Sponsored by: DARPA Differential Revision: https://reviews.freebsd.org/D42977
Diffstat (limited to 'science/paraview')
-rw-r--r--science/paraview/Makefile4
-rw-r--r--science/paraview/files/patch-VTK_ThirdParty_xdmf2_vtkxdmf2_libsrc_XdmfArray.cxx12
2 files changed, 13 insertions, 3 deletions
diff --git a/science/paraview/Makefile b/science/paraview/Makefile
index 14c9d232bec4..2e42363cbee1 100644
--- a/science/paraview/Makefile
+++ b/science/paraview/Makefile
@@ -1,6 +1,6 @@
PORTNAME= paraview
DISTVERSION= ${PARAVIEW_VER}.2
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= science graphics
MASTER_SITES= http://www.paraview.org/files/v${PARAVIEW_VER}/
DISTNAME= ParaView-v${PORTVERSION}
@@ -14,8 +14,6 @@ LICENSE_NAME= ParaView_License
LICENSE_FILE= ${WRKSRC}/License_v1.2.txt
LICENSE_PERMS= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
-BROKEN_aarch64= fails to link: undefined reference to `sbrk'
-
BUILD_DEPENDS= ${PYNUMPY} \
cli11>0:devel/cli11 \
utf8cpp>0:devel/utf8cpp \
diff --git a/science/paraview/files/patch-VTK_ThirdParty_xdmf2_vtkxdmf2_libsrc_XdmfArray.cxx b/science/paraview/files/patch-VTK_ThirdParty_xdmf2_vtkxdmf2_libsrc_XdmfArray.cxx
new file mode 100644
index 000000000000..670b45c2d42e
--- /dev/null
+++ b/science/paraview/files/patch-VTK_ThirdParty_xdmf2_vtkxdmf2_libsrc_XdmfArray.cxx
@@ -0,0 +1,12 @@
+--- VTK/ThirdParty/xdmf2/vtkxdmf2/libsrc/XdmfArray.cxx.orig
++++ VTK/ThirdParty/xdmf2/vtkxdmf2/libsrc/XdmfArray.cxx
+@@ -310,9 +310,6 @@
+ if( this->DataPointer == NULL ) {
+ XdmfDebug("Allocation Failed");
+ perror(" Alloc :" );
+-#ifndef _WIN32
+- XdmfDebug("End == " << sbrk(0) );
+-#endif
+ }
+ }
+ XdmfDebug("Data Pointer = " << this->DataPointer );