aboutsummaryrefslogtreecommitdiff
path: root/science/pcmsolver
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2020-12-03 10:49:31 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2020-12-03 10:49:31 +0000
commit0a251962d669598e4656bcdc8161b0de7c201325 (patch)
tree6dba99a66823da1d766d21adfa5d050cb2b63b44 /science/pcmsolver
parent9c420086450ff6a8d7de8c6376858cde6b5645ca (diff)
downloadports-0a251962d669598e4656bcdc8161b0de7c201325.tar.gz
ports-0a251962d669598e4656bcdc8161b0de7c201325.zip
science/pcmsolver: Update 1.2.3 -> 1.3.0
Reported by: portscout
Notes
Notes: svn path=/head/; revision=556896
Diffstat (limited to 'science/pcmsolver')
-rw-r--r--science/pcmsolver/Makefile10
-rw-r--r--science/pcmsolver/distinfo6
-rw-r--r--science/pcmsolver/files/patch-CMakeLists.txt14
-rw-r--r--science/pcmsolver/pkg-plist3
4 files changed, 15 insertions, 18 deletions
diff --git a/science/pcmsolver/Makefile b/science/pcmsolver/Makefile
index 0580c59ff37d..c7f8bde46968 100644
--- a/science/pcmsolver/Makefile
+++ b/science/pcmsolver/Makefile
@@ -2,8 +2,7 @@
PORTNAME= pcmsolver
DISTVERSIONPREFIX= v
-DISTVERSION= 1.2.3
-PORTREVISION= 2
+DISTVERSION= 1.3.0
CATEGORIES= science
MAINTAINER= yuri@FreeBSD.org
@@ -13,9 +12,10 @@ LICENSE= GPLv3
LICENSE_FILE= ${WRKSRC}/LICENSE
USES= cmake:noninja compiler:c11 fortran python
+USE_LDCONFIG= yes
+
USE_GITHUB= yes
GH_ACCOUNT= PCMSolver
-USE_LDCONFIG= yes
do-configure: # full CMAKE_ARGS breaks configure: -DCMAKE_EXE_LINKER_FLAGS="${LDFLAGS}" causes configure to fail to find fortran's libraries
@${MKDIR} ${CONFIGURE_WRKSRC}
@@ -29,8 +29,4 @@ do-configure: # full CMAKE_ARGS breaks configure: -DCMAKE_EXE_LINKER_FLAGS="${LD
-DCMAKE_CXX_COMPILER:STRING="${CXX}" \
${CMAKE_SOURCE_PATH}
-post-patch:
- @${REINPLACE_CMD} -e 's|"-O3 |"$${CMAKE_C_FLAGS} |' \
- ${WRKSRC}/cmake/custom/compilers/*.cmake
-
.include <bsd.port.mk>
diff --git a/science/pcmsolver/distinfo b/science/pcmsolver/distinfo
index 10d563ade416..a6dc5133d03e 100644
--- a/science/pcmsolver/distinfo
+++ b/science/pcmsolver/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1550370476
-SHA256 (PCMSolver-pcmsolver-v1.2.3_GH0.tar.gz) = d1ef6bdc268a2e719b36c85125c3543df7a26e1a738daf4483f4ded0c76f5b60
-SIZE (PCMSolver-pcmsolver-v1.2.3_GH0.tar.gz) = 98222156
+TIMESTAMP = 1606986290
+SHA256 (PCMSolver-pcmsolver-v1.3.0_GH0.tar.gz) = 85d40881e3dbdb13e9b8dc661cd576c181760f6e0d760ab5630b5a8155418f34
+SIZE (PCMSolver-pcmsolver-v1.3.0_GH0.tar.gz) = 98241099
diff --git a/science/pcmsolver/files/patch-CMakeLists.txt b/science/pcmsolver/files/patch-CMakeLists.txt
index e49387be7c1c..622c67d02256 100644
--- a/science/pcmsolver/files/patch-CMakeLists.txt
+++ b/science/pcmsolver/files/patch-CMakeLists.txt
@@ -1,10 +1,10 @@
---- CMakeLists.txt.orig 2018-12-19 05:45:58 UTC
+--- CMakeLists.txt.orig 2020-11-30 20:21:39 UTC
+++ CMakeLists.txt
-@@ -80,4 +80,6 @@ include(eigen)
- include(libtaylor)
- include(zlib)
- include(autocmake_src)
--include(test)
+@@ -75,4 +75,6 @@ include(${PROJECT_SOURCE_DIR}/cmake/custom/eigen.cmake
+ include(${PROJECT_SOURCE_DIR}/cmake/custom/libtaylor.cmake)
+ include(${PROJECT_SOURCE_DIR}/cmake/custom/zlib.cmake)
+ include(${PROJECT_SOURCE_DIR}/cmake/downloaded/autocmake_src.cmake)
+-include(${PROJECT_SOURCE_DIR}/cmake/custom/test.cmake)
+if (BUILD_TESTING)
-+ include(test)
++ include(${PROJECT_SOURCE_DIR}/cmake/custom/test.cmake)
+endif()
diff --git a/science/pcmsolver/pkg-plist b/science/pcmsolver/pkg-plist
index 0cc2715c4bb3..d1ff76a57d6b 100644
--- a/science/pcmsolver/pkg-plist
+++ b/science/pcmsolver/pkg-plist
@@ -3,7 +3,6 @@ bin/plot_cavity.py
bin/run_pcm
include/PCMSolver/Citation.hpp
include/PCMSolver/Config.hpp
-include/PCMSolver/Cxx11Workarounds.hpp
include/PCMSolver/ErrorHandling.hpp
include/PCMSolver/LoggerInterface.hpp
include/PCMSolver/PCMInput.h
@@ -50,6 +49,7 @@ include/PCMSolver/green/UniformDielectric.hpp
include/PCMSolver/green/Vacuum.hpp
include/PCMSolver/interface/Input.hpp
include/PCMSolver/interface/Meddle.hpp
+include/PCMSolver/mmfq/FQOhno.hpp
include/PCMSolver/pcmsolver.f90
include/PCMSolver/pcmsolver.h
include/PCMSolver/solver/CPCMSolver.hpp
@@ -64,6 +64,7 @@ include/PCMSolver/utils/Factory.hpp
include/PCMSolver/utils/Legendre.hpp
include/PCMSolver/utils/Logger.hpp
include/PCMSolver/utils/LoggerImpl.hpp
+include/PCMSolver/utils/MMFQ.hpp
include/PCMSolver/utils/MathUtils.hpp
include/PCMSolver/utils/Molecule.hpp
include/PCMSolver/utils/QuadratureRules.hpp