aboutsummaryrefslogtreecommitdiff
path: root/science/py-GPy
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2018-12-18 06:24:14 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2018-12-18 06:24:14 +0000
commit4c4a05c73ce8986b621767ee410c3161ea181690 (patch)
tree8bd1b3fb8131fad13c43945498024bb2ea73d189 /science/py-GPy
parent6bb36770f52b40b1fbdee711ffbfa1f3aa1cfc3f (diff)
downloadports-4c4a05c73ce8986b621767ee410c3161ea181690.tar.gz
ports-4c4a05c73ce8986b621767ee410c3161ea181690.zip
Notes
Diffstat (limited to 'science/py-GPy')
-rw-r--r--science/py-GPy/Makefile25
-rw-r--r--science/py-GPy/distinfo3
-rw-r--r--science/py-GPy/pkg-descr8
3 files changed, 36 insertions, 0 deletions
diff --git a/science/py-GPy/Makefile b/science/py-GPy/Makefile
new file mode 100644
index 000000000000..ca1adc883309
--- /dev/null
+++ b/science/py-GPy/Makefile
@@ -0,0 +1,25 @@
+# $FreeBSD$
+
+PORTNAME= GPy
+DISTVERSION= 1.9.6
+CATEGORIES= science python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Gaussian process toolbox
+
+LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE.txt
+
+BUILD_DEPENDS= ${PYNUMPY}
+LIB_DEPENDS= libomp.so:devel/openmp
+RUN_DEPENDS= ${PYNUMPY} \
+ ${PYTHON_PKGNAMEPREFIX}scipy>=0.16:science/py-scipy@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}six>0:devel/py-six@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}paramz>=0.9.0:science/py-paramz@${PY_FLAVOR}
+
+USES= localbase python
+USE_PYTHON= distutils autoplist
+
+.include <bsd.port.mk>
diff --git a/science/py-GPy/distinfo b/science/py-GPy/distinfo
new file mode 100644
index 000000000000..659f0f1032b7
--- /dev/null
+++ b/science/py-GPy/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1545112527
+SHA256 (GPy-1.9.6.tar.gz) = f11d649b3320d4cb836d283706754953277c8696977726803ccd3ee1355a94a7
+SIZE (GPy-1.9.6.tar.gz) = 873746
diff --git a/science/py-GPy/pkg-descr b/science/py-GPy/pkg-descr
new file mode 100644
index 000000000000..5febbe57a551
--- /dev/null
+++ b/science/py-GPy/pkg-descr
@@ -0,0 +1,8 @@
+GPy is a Gaussian Process (GP) framework written in python, from the Sheffield
+machine learning group.
+
+Gaussian processes underpin range of modern machine learning algorithms. In GPy,
+we've used python to implement a range of machine learning algorithms based on
+GPs.
+
+WWW: https://sheffieldml.github.io/GPy/