aboutsummaryrefslogtreecommitdiff
path: root/science/py-asdf/Makefile
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2022-08-31 11:24:12 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2022-08-31 11:41:12 +0000
commitaec044501eb30df5ec140ba0a929c2421700117b (patch)
tree280544b59f5fd50b8164147bf66ac3eb70c8821b /science/py-asdf/Makefile
parent6765131a95d64c12db0ff2f0d726b3216ba44b5c (diff)
downloadports-aec044501eb30df5ec140ba0a929c2421700117b.tar.gz
ports-aec044501eb30df5ec140ba0a929c2421700117b.zip
science/py-asdf: Update to 2.13.0
Diffstat (limited to 'science/py-asdf/Makefile')
-rw-r--r--science/py-asdf/Makefile8
1 files changed, 5 insertions, 3 deletions
diff --git a/science/py-asdf/Makefile b/science/py-asdf/Makefile
index b39d89f2ca6a..1f019aff334a 100644
--- a/science/py-asdf/Makefile
+++ b/science/py-asdf/Makefile
@@ -1,5 +1,5 @@
PORTNAME= asdf
-PORTVERSION= 2.12.0
+PORTVERSION= 2.13.0
CATEGORIES= science python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -10,11 +10,10 @@ COMMENT= Python tools to handle ASDF files
LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE
-BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}setuptools_scm>=0:devel/py-setuptools_scm@${PY_FLAVOR}
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}asdf-standard>=1.0.1:science/py-asdf-standard@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}asdf-transform-schemas>=0.2.2:science/py-asdf-transform-schemas@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}jmespath>=0.6.2:devel/py-jmespath@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}jsonschema>=4.0.1:devel/py-jsonschema@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}jsonschema>=4.0.1<4.10.0:devel/py-jsonschema@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}lz4>=0.10:archivers/py-lz4@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}numpy>=1.10,1:math/py-numpy@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}packaging>=16.0:devel/py-packaging@${PY_FLAVOR} \
@@ -32,4 +31,7 @@ NO_ARCH= yes
RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}importlib-resources>=3:devel/py-importlib-resources@${PY_FLAVOR}
.endif
+post-patch:
+ @${SED} -e 's|%%PORTVERSION%%|${PORTVERSION}|' ${FILESDIR}/setup.py > ${WRKSRC}/setup.py
+
.include <bsd.port.post.mk>