aboutsummaryrefslogtreecommitdiff
path: root/science/py-asdf
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2019-01-17 19:21:25 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2019-01-17 19:21:25 +0000
commit5542508c35d1e4fc2ac3c484dd497fdc792742e1 (patch)
tree5a63a4bed4a69171938e487f377ed3858f98aee6 /science/py-asdf
parentbde795881fddbfdb05256917237ec01ffebd5bf4 (diff)
downloadports-5542508c35d1e4fc2ac3c484dd497fdc792742e1.tar.gz
ports-5542508c35d1e4fc2ac3c484dd497fdc792742e1.zip
Add py-asdf 2.3.1
The Advanced Scientific Data Format (ASDF) is a next-generation interchange format for scientific data. This package contains the Python implementation of the ASDF Standard. The ASDF format has the following features: - A hierarchical, human-readable metadata format (implemented using YAML) - Numerical arrays are stored as binary data blocks which can be memory mapped. Data blocks can optionally be compressed. - The structure of the data can be automatically validated using schemas (implemented using JSON Schema) - Native Python data types (numerical types, strings, dicts, lists) are serialized automatically - ASDF can be extended to serialize custom data types WWW: https://github.com/spacetelescope/asdf
Notes
Notes: svn path=/head/; revision=490586
Diffstat (limited to 'science/py-asdf')
-rw-r--r--science/py-asdf/Makefile28
-rw-r--r--science/py-asdf/distinfo3
-rw-r--r--science/py-asdf/pkg-descr15
3 files changed, 46 insertions, 0 deletions
diff --git a/science/py-asdf/Makefile b/science/py-asdf/Makefile
new file mode 100644
index 000000000000..96375f661ad6
--- /dev/null
+++ b/science/py-asdf/Makefile
@@ -0,0 +1,28 @@
+# Created by: Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= asdf
+PORTVERSION= 2.3.1
+CATEGORIES= science python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Python tools to handle ASDF files
+
+LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/licenses/LICENSE.rst
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}jsonschema>=2.3:devel/py-jsonschema@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}lz4>=0.10:archivers/py-lz4@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}numpy>=1.8:math/py-numpy@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}semantic_version>=2.3.1:devel/py-semantic_version@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}six>=1.9.0:devel/py-six@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}yaml>=3.10:devel/py-yaml@${PY_FLAVOR}
+
+USES= python:3.3+
+USE_PYTHON= autoplist distutils
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/science/py-asdf/distinfo b/science/py-asdf/distinfo
new file mode 100644
index 000000000000..c01a32c82301
--- /dev/null
+++ b/science/py-asdf/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1547699123
+SHA256 (asdf-2.3.1.tar.gz) = deea56c2c685e56802bfd328f9df9a60b4d209774251c4166a2605b4ad023697
+SIZE (asdf-2.3.1.tar.gz) = 577885
diff --git a/science/py-asdf/pkg-descr b/science/py-asdf/pkg-descr
new file mode 100644
index 000000000000..2abf6ca62b3b
--- /dev/null
+++ b/science/py-asdf/pkg-descr
@@ -0,0 +1,15 @@
+The Advanced Scientific Data Format (ASDF) is a next-generation interchange
+format for scientific data. This package contains the Python implementation of
+the ASDF Standard.
+
+The ASDF format has the following features:
+- A hierarchical, human-readable metadata format (implemented using YAML)
+- Numerical arrays are stored as binary data blocks which can be memory mapped.
+ Data blocks can optionally be compressed.
+- The structure of the data can be automatically validated using schemas
+ (implemented using JSON Schema)
+- Native Python data types (numerical types, strings, dicts, lists) are
+ serialized automatically
+- ASDF can be extended to serialize custom data types
+
+WWW: https://github.com/spacetelescope/asdf