aboutsummaryrefslogtreecommitdiff
path: root/science/py-chainer
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2019-08-08 20:07:04 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2019-08-08 20:07:04 +0000
commit48bb80d29b6dbc8f64b78569731655c5af0cf21c (patch)
tree1852e0c5c52088ce077c10f98a8f1f7d2be5bde4 /science/py-chainer
parentd3f552d9f109fa49e34765a04458f025a216d4c7 (diff)
downloadports-48bb80d29b6dbc8f64b78569731655c5af0cf21c.tar.gz
ports-48bb80d29b6dbc8f64b78569731655c5af0cf21c.zip
New port: science/py-chainer: Deep learning framework
Notes
Notes: svn path=/head/; revision=508402
Diffstat (limited to 'science/py-chainer')
-rw-r--r--science/py-chainer/Makefile26
-rw-r--r--science/py-chainer/distinfo3
-rw-r--r--science/py-chainer/pkg-descr11
3 files changed, 40 insertions, 0 deletions
diff --git a/science/py-chainer/Makefile b/science/py-chainer/Makefile
new file mode 100644
index 000000000000..4bae764ef19e
--- /dev/null
+++ b/science/py-chainer/Makefile
@@ -0,0 +1,26 @@
+# $FreeBSD$
+
+PORTNAME= chainer
+DISTVERSION= 6.2.0
+CATEGORIES= science biology
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Deep learning framework
+
+LICENSE= MIT
+
+LIB_DEPENDS= libprotobuf.so:devel/protobuf
+RUN_DEPENDS= ${PYNUMPY} \
+ ${PYTHON_PKGNAMEPREFIX}filelock>0:sysutils/py-filelock@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}six>=1.9.0:devel/py-six@${PY_FLAVOR} \
+ ${PY_TYPING} \
+ ${PYTHON_PKGNAMEPREFIX}typing-extensions>0:devel/py-typing-extensions@${PY_FLAVOR}
+
+USES= python
+USE_PYTHON= distutils autoplist
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/science/py-chainer/distinfo b/science/py-chainer/distinfo
new file mode 100644
index 000000000000..650faf3f8d16
--- /dev/null
+++ b/science/py-chainer/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1565290777
+SHA256 (chainer-6.2.0.tar.gz) = 59ffacca815ccad80acca218f111ada6d4507a8f69e3ac3f135f489219c4d86f
+SIZE (chainer-6.2.0.tar.gz) = 873060
diff --git a/science/py-chainer/pkg-descr b/science/py-chainer/pkg-descr
new file mode 100644
index 000000000000..3ce9ee5662f2
--- /dev/null
+++ b/science/py-chainer/pkg-descr
@@ -0,0 +1,11 @@
+Chainer is a powerful, flexible and intuitive deep learning framework.
+* Chainer supports CUDA computation. It only requires a few lines of code to
+ leverage a GPU. It also runs on multiple GPUs with little effort.
+* Chainer supports various network architectures including feed-forward nets,
+ convnets, recurrent nets and recursive nets. It also supports per-batch
+ architectures.
+* Forward computation can include any control flow statements of Python without
+ lacking the ability of backpropagation. It makes code intuitive and easy to
+ debug.
+
+WWW: https://chainer.org/