aboutsummaryrefslogtreecommitdiff
path: root/science/py-gpaw
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2018-09-01 18:31:54 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2018-09-01 18:31:54 +0000
commit70dd01bab580ed24555f6315f055a9243080bccc (patch)
treeca3b2078a057e96f2c1c0ec5984a560b13d1f69b /science/py-gpaw
parent6eb7a59ccdec38da114bbef7c0c1db8113f4eda3 (diff)
downloadports-70dd01bab580ed24555f6315f055a9243080bccc.tar.gz
ports-70dd01bab580ed24555f6315f055a9243080bccc.zip
New port: science/py-gpaw: DFT and beyond within the projector-augmented wave method in chemistry
Notes
Notes: svn path=/head/; revision=478713
Diffstat (limited to 'science/py-gpaw')
-rw-r--r--science/py-gpaw/Makefile30
-rw-r--r--science/py-gpaw/distinfo3
-rw-r--r--science/py-gpaw/pkg-descr6
3 files changed, 39 insertions, 0 deletions
diff --git a/science/py-gpaw/Makefile b/science/py-gpaw/Makefile
new file mode 100644
index 000000000000..a3aad0e5a863
--- /dev/null
+++ b/science/py-gpaw/Makefile
@@ -0,0 +1,30 @@
+# $FreeBSD$
+
+PORTNAME= gpaw
+DISTVERSION= 1.4.0
+CATEGORIES= science python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= DFT and beyond within the projector-augmented wave method in chemistry
+
+LICENSE= GPLv3+
+
+BUILD_DEPENDS= ${PYNUMPY}
+LIB_DEPENDS= libmpich.so:net/mpich2 \
+ libopenblas.so:math/openblas \
+ libxc.so:science/libxc
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}ase>0:science/py-ase@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}matplotlib>0:math/py-matplotlib@${PY_FLAVOR} \
+ ${PYNUMPY}
+
+USES= gettext-runtime localbase python shebangfix
+GH_ACCOUNT= psychopy
+USE_PYTHON= distutils concurrent autoplist
+SHEBANG_FILES= tools/*
+
+post-install:
+ @${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/gpaw-python ${STAGEDIR}${PYTHONPREFIX_SITELIBDIR}/_gpaw.so
+
+.include <bsd.port.mk>
diff --git a/science/py-gpaw/distinfo b/science/py-gpaw/distinfo
new file mode 100644
index 000000000000..832e5157d08e
--- /dev/null
+++ b/science/py-gpaw/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1534999050
+SHA256 (gpaw-1.4.0.tar.gz) = 9d4f4ab13f179c4998e33997cb06e4a66698a19b64c283e4dfaf9aab3be66ccc
+SIZE (gpaw-1.4.0.tar.gz) = 1379946
diff --git a/science/py-gpaw/pkg-descr b/science/py-gpaw/pkg-descr
new file mode 100644
index 000000000000..21ddb9140a0d
--- /dev/null
+++ b/science/py-gpaw/pkg-descr
@@ -0,0 +1,6 @@
+GPAW is a density-functional theory (DFT) Python code based on the
+projector-augmented wave (PAW) method and the atomic simulation
+environment (ASE). It uses plane-waves, atom-centered basis-functions
+or real-space uniform grids combined with multigrid methods.
+
+WWW: https://wiki.fysik.dtu.dk/gpaw/