aboutsummaryrefslogtreecommitdiff
path: root/science/py-h5py/files
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2021-01-26 17:37:37 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2021-01-26 17:37:37 +0000
commitaac1d790a16d8a4239a1cd7e6dfbe786f8caa5b1 (patch)
treeddf10d008954f97426ce9b5aa33ba209de8c3105 /science/py-h5py/files
parente335b8d642df0b9a771f53c8b5f2dee5dfd2a4ac (diff)
downloadports-aac1d790a16d8a4239a1cd7e6dfbe786f8caa5b1.tar.gz
ports-aac1d790a16d8a4239a1cd7e6dfbe786f8caa5b1.zip
Notes
Diffstat (limited to 'science/py-h5py/files')
-rw-r--r--science/py-h5py/files/patch-setup.py23
1 files changed, 23 insertions, 0 deletions
diff --git a/science/py-h5py/files/patch-setup.py b/science/py-h5py/files/patch-setup.py
new file mode 100644
index 000000000000..3a3544a35b81
--- /dev/null
+++ b/science/py-h5py/files/patch-setup.py
@@ -0,0 +1,23 @@
+--- setup.py.orig 2020-11-06 14:25:11 UTC
++++ setup.py
+@@ -27,10 +27,7 @@ VERSION = '3.1.0'
+ # Minimum supported versions of Numpy & Cython depend on the Python version
+ NUMPY_MIN_VERSIONS = [
+ # Numpy Python
+- ('1.12', "=='3.6'"),
+- ('1.14.5', "=='3.7'"),
+- ('1.17.5', "=='3.8'"),
+- ('1.19.3', ">='3.9'"),
++ ('1.14.5', ">='3.6'"),
+ ]
+
+ # these are required to use h5py
+@@ -49,7 +46,7 @@ SETUP_REQUIRES = [
+ f"Cython >=0.29; python_version<'3.8'",
+ f"Cython >=0.29.14; python_version>='3.8'",
+ ] + [
+- f"numpy =={np_min}; python_version{py_condition}"
++ f"numpy >={np_min}; python_version{py_condition}"
+ for np_min, py_condition in NUMPY_MIN_VERSIONS
+ ]
+