aboutsummaryrefslogtreecommitdiff
path: root/science/py-h5py
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2018-02-25 01:24:18 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2018-02-25 01:24:18 +0000
commitc61d2c3b308fef7701011ec9b69375346913882f (patch)
tree4e1996967041c52cd6be01c29305db96f380ef19 /science/py-h5py
parent2615879be7652d0600bf83152178ca869fd00808 (diff)
downloadports-c61d2c3b308fef7701011ec9b69375346913882f.tar.gz
ports-c61d2c3b308fef7701011ec9b69375346913882f.zip
science/py-h5py: Update to 2.7.1
Additional port changes: * Changed to DISTVERSION * Grouped USExx * Added USE_PYTHON=concurrent (for docs, examples) * Removed patching (in post-patch and files/) * Added stripping * Updated WWW Approved by: tcberner (mentor, implicit)
Notes
Notes: svn path=/head/; revision=462889
Diffstat (limited to 'science/py-h5py')
-rw-r--r--science/py-h5py/Makefile15
-rw-r--r--science/py-h5py/distinfo6
-rw-r--r--science/py-h5py/files/patch-setup__build.py13
-rw-r--r--science/py-h5py/pkg-descr2
4 files changed, 11 insertions, 25 deletions
diff --git a/science/py-h5py/Makefile b/science/py-h5py/Makefile
index 3f4514175d42..cd6f35a55650 100644
--- a/science/py-h5py/Makefile
+++ b/science/py-h5py/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= h5py
-PORTVERSION= 2.7.0
+DISTVERSION= 2.7.1
CATEGORIES= science python
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -19,10 +19,9 @@ LIB_DEPENDS= libhdf5.so:science/hdf5
RUN_DEPENDS= ${PYNUMPY} \
${PYTHON_PKGNAMEPREFIX}six>0:devel/py-six@${FLAVOR}
-USE_GITHUB= yes
-
USES= python
-USE_PYTHON= autoplist distutils cython
+USE_GITHUB= yes
+USE_PYTHON= distutils cython autoplist concurrent
PORTDOCS= *
PORTEXAMPLES= multiprocessing_example.py swmr_multiprocess.py \
@@ -30,9 +29,6 @@ PORTEXAMPLES= multiprocessing_example.py swmr_multiprocess.py \
OPTIONS_DEFINE= DOCS EXAMPLES
-post-patch:
- ${REINPLACE_CMD} -e 's|%%PREFIX%%|${PREFIX}|' ${WRKSRC}/setup_build.py
-
do-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/README.rst ${STAGEDIR}${DOCSDIR}
@@ -42,7 +38,10 @@ do-install-EXAMPLES-on:
@${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
${INSTALL_DATA} ${PORTEXAMPLES:S|^|${WRKSRC}/examples/|} ${STAGEDIR}${EXAMPLESDIR}
+post-install:
+ @${STRIP_CMD} ${STAGEDIR}${PYTHONPREFIX_SITELIBDIR}/h5py/*.so
+
do-test:
- cd ${WRKSRC} && ${PYTHON_CMD} ${PYSETUP} test
+ @cd ${WRKSRC} && ${PYTHON_CMD} ${PYSETUP} test
.include <bsd.port.mk>
diff --git a/science/py-h5py/distinfo b/science/py-h5py/distinfo
index 2b74ba21dcb6..a27265610dbd 100644
--- a/science/py-h5py/distinfo
+++ b/science/py-h5py/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1496507199
-SHA256 (h5py-h5py-2.7.0_GH0.tar.gz) = fff3a878c6adfa1b4f5c30b558a295d52dd4fee9174128c626ef416dec1b536b
-SIZE (h5py-h5py-2.7.0_GH0.tar.gz) = 265122
+TIMESTAMP = 1519520436
+SHA256 (h5py-h5py-2.7.1_GH0.tar.gz) = 55bdefda47c49973ec24384097d18eb5f84797c057aaf0bf0b6b0f7860ad43e7
+SIZE (h5py-h5py-2.7.1_GH0.tar.gz) = 268457
diff --git a/science/py-h5py/files/patch-setup__build.py b/science/py-h5py/files/patch-setup__build.py
deleted file mode 100644
index cd89d09b10ee..000000000000
--- a/science/py-h5py/files/patch-setup__build.py
+++ /dev/null
@@ -1,13 +0,0 @@
---- setup_build.py.orig 2017-06-03 16:40:14 UTC
-+++ setup_build.py
-@@ -49,8 +49,8 @@ if sys.platform.startswith('win'):
- ('H5_BUILT_AS_DYNAMIC_LIB', None)
- ])
- else:
-- COMPILER_SETTINGS['include_dirs'].extend(['/opt/local/include''/usr/local/include'])
-- COMPILER_SETTINGS['library_dirs'].extend(['/opt/local/include''/usr/local/include'])
-+ COMPILER_SETTINGS['include_dirs'].extend(['%%PREFIX%%/include'])
-+ COMPILER_SETTINGS['library_dirs'].extend(['%%PREFIX%%/lib'])
-
-
- class h5py_build_ext(build_ext):
diff --git a/science/py-h5py/pkg-descr b/science/py-h5py/pkg-descr
index 4394c3d5f3f0..35d1d981f7b9 100644
--- a/science/py-h5py/pkg-descr
+++ b/science/py-h5py/pkg-descr
@@ -9,4 +9,4 @@ to the existing HDF5 API and abstractions, so that Python programs can
easily deal with HDF5 files and exchange data with other HDF5-aware
applications.
-WWW: http://h5py.alfven.org
+WWW: https://www.h5py.org