aboutsummaryrefslogtreecommitdiff
path: root/science/py-h5py
diff options
context:
space:
mode:
authorKubilay Kocak <koobs@FreeBSD.org>2013-08-13 11:59:54 +0000
committerKubilay Kocak <koobs@FreeBSD.org>2013-08-13 11:59:54 +0000
commitc90936db20ebd7d664ecf21f2406c81571225b90 (patch)
tree2a16fc5c4c567e0bb9c7e0985ee1d2dd79a82f46 /science/py-h5py
parentc42445da898499b5071bc6a5b5a83fe535c5b9f9 (diff)
downloadports-c90936db20ebd7d664ecf21f2406c81571225b90.tar.gz
ports-c90936db20ebd7d664ecf21f2406c81571225b90.zip
science/py-h5py: Add OPTION support for HDF5 1.8
- Add OPTION to use science/hdf5-18 instead of science/hdf5 PR: ports/179572 Submitted by: Johannes Meixner <xmj@chaot.net> Approved by: maintainer timeout (8 weeks)
Notes
Notes: svn path=/head/; revision=324659
Diffstat (limited to 'science/py-h5py')
-rw-r--r--science/py-h5py/Makefile20
-rw-r--r--science/py-h5py/pkg-descr9
2 files changed, 17 insertions, 12 deletions
diff --git a/science/py-h5py/Makefile b/science/py-h5py/Makefile
index ba2ef6b20514..14ab4b1b6e26 100644
--- a/science/py-h5py/Makefile
+++ b/science/py-h5py/Makefile
@@ -1,13 +1,9 @@
-# Ports collection makefile for: h5py
-# Date created: Jun 22, 2009
-# Whom: TAOKA Fumiyoshi
-#
+# Created by: TAOKA Fumiyoshi
# $FreeBSD$
-#
PORTNAME= h5py
PORTVERSION= 1.2.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= science python
MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE}
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -17,7 +13,17 @@ COMMENT= A general-purpose Python interface to the HDF5 library
BUILD_DEPENDS= ${PYNUMPY}
RUN_DEPENDS= ${PYNUMPY}
-LIB_DEPENDS= hdf5.0:${PORTSDIR}/science/hdf5
+
+OPTIONS_DEFINE= NEW_HDF5
+NEW_HDF5_DESC= Use port science/hdf5-18 instead of science/hdf5
+OPTIONSFILE?= ${PORT_DBDIR}/py-${PORTNAME}/options
+
+.include <bsd.port.options.mk>
+.if ${PORT_OPTIONS:MNEW_HDF5}
+LIB_DEPENDS= hdf5:${PORTSDIR}/science/hdf5-18
+.else
+LIB_DEPENDS= hdf5:${PORTSDIR}/science/hdf5
+.endif
USE_PYTHON= 2.5+
USE_PYDISTUTILS= easy_install
diff --git a/science/py-h5py/pkg-descr b/science/py-h5py/pkg-descr
index aa2bfff6c030..a33e117ddee5 100644
--- a/science/py-h5py/pkg-descr
+++ b/science/py-h5py/pkg-descr
@@ -1,8 +1,7 @@
-The h5py package provides both a high- and low-level interface to the
-HDF5 library from Python. The low-level interface is
-intended to be a complete wrapping of the HDF5 1.6 API, while the high-
-level component supports Python-style object-oriented access to HDF5 files,
-datasets and groups.
+The h5py package provides both a high- and low-level interface to the HDF5
+library from Python. The low-level interface is intended to be a complete
+wrapping of the HDF5 1.6 and 1.8 APIs, while the high-level component supports
+Python-style object-oriented access to HDF5 files, datasets and groups.
The goal of this package is not to provide yet another scientific data
model. It is an attempt to create as straightforward a binding as possible