aboutsummaryrefslogtreecommitdiff
path: root/science/py-hcluster/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-09-26 23:21:54 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-09-26 23:21:54 +0000
commitb7fded52757f61da72c564630a4476b827af90e5 (patch)
tree08f3aa402015dfc354a874890d049d744b528fd1 /science/py-hcluster/Makefile
parentea8741ec5a9fd72fb841bc35f3c626ef889f0275 (diff)
downloadports-b7fded52757f61da72c564630a4476b827af90e5.tar.gz
ports-b7fded52757f61da72c564630a4476b827af90e5.zip
Notes
Diffstat (limited to 'science/py-hcluster/Makefile')
-rw-r--r--science/py-hcluster/Makefile23
1 files changed, 23 insertions, 0 deletions
diff --git a/science/py-hcluster/Makefile b/science/py-hcluster/Makefile
new file mode 100644
index 000000000000..fb5236dabc53
--- /dev/null
+++ b/science/py-hcluster/Makefile
@@ -0,0 +1,23 @@
+# New ports collection makefile for: py-hcluster
+# Date created: 2008-09-04
+# Whom: Wen Heping <wenheping@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= hcluster
+PORTVERSION= 0.1.9
+CATEGORIES= science python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= wenheping@gmail.com
+COMMENT= A Hierarchical Clustering Package For Scipy
+
+BUILD_DEPENDS= ${PYTHON_SITELIBDIR}/numpy:${PORTSDIR}/math/py-numpy
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+USE_PYTHON= yes
+USE_PYDISTUTILS= yes
+
+.include <bsd.port.mk>