aboutsummaryrefslogtreecommitdiff
path: root/science/py-kinematics
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2021-01-10 23:14:07 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2021-01-10 23:14:07 +0000
commit57a53c376f0f5673484161269470760b6c234d4a (patch)
tree41c45fc51bc6d06a4c7b43305911627c5bc34d41 /science/py-kinematics
parent4bc446735c050343689ad0cad7e631d53779f31a (diff)
downloadports-57a53c376f0f5673484161269470760b6c234d4a.tar.gz
ports-57a53c376f0f5673484161269470760b6c234d4a.zip
Remove py-pytest-runner from BUILD_DEPENDS
Notes
Notes: svn path=/head/; revision=561149
Diffstat (limited to 'science/py-kinematics')
-rw-r--r--science/py-kinematics/Makefile1
-rw-r--r--science/py-kinematics/files/patch-setup.py10
2 files changed, 10 insertions, 1 deletions
diff --git a/science/py-kinematics/Makefile b/science/py-kinematics/Makefile
index 2de0b31ad207..f514e5d912fd 100644
--- a/science/py-kinematics/Makefile
+++ b/science/py-kinematics/Makefile
@@ -12,7 +12,6 @@ COMMENT= Python module to do attitude kinematics
LICENSE= GPLv3
-BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytest-runner>=0:devel/py-pytest-runner@${PY_FLAVOR}
RUN_DEPENDS= ${PYNUMPY}
TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}coverage>=0:devel/py-coverage@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}pytest>=0:devel/py-pytest@${PY_FLAVOR} \
diff --git a/science/py-kinematics/files/patch-setup.py b/science/py-kinematics/files/patch-setup.py
new file mode 100644
index 000000000000..fe9ee7c6a4f0
--- /dev/null
+++ b/science/py-kinematics/files/patch-setup.py
@@ -0,0 +1,10 @@
+--- setup.py.orig 2018-12-08 03:30:44 UTC
++++ setup.py
+@@ -88,7 +88,6 @@ setup(
+ },
+
+ # testing requires for pytest
+- setup_requires=['pytest-runner'],
+
+ tests_require=['pytest'],
+