aboutsummaryrefslogtreecommitdiff
path: root/science/py-liac-arff
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2020-05-16 10:49:37 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2020-05-16 10:49:37 +0000
commitb7cffbb589cbc45d7aed195b4371dfa664578e98 (patch)
tree9eb5499becb4c1b0596f6a9a449f0847e3c19ed0 /science/py-liac-arff
parent2112825c09788163bc69b716e15979a80fa1d9e9 (diff)
downloadports-b7cffbb589cbc45d7aed195b4371dfa664578e98.tar.gz
ports-b7cffbb589cbc45d7aed195b4371dfa664578e98.zip
Add py-liac-arff 2.4.0
The liac-arff module implements functions to read and write ARFF files in Python. It was created in the Connectionist Artificial Intelligence Laboratory (LIAC), which takes place at the Federal University of Rio Grande do Sul (UFRGS), in Brazil. ARFF (Attribute-Relation File Format) is an file format specially created for describe datasets which are used commonly for machine learning experiments and softwares. This file format was created to be used in Weka, the best representative software for machine learning automated experiments. WWW: https://github.com/renatopp/liac-arff
Notes
Notes: svn path=/head/; revision=535382
Diffstat (limited to 'science/py-liac-arff')
-rw-r--r--science/py-liac-arff/Makefile22
-rw-r--r--science/py-liac-arff/distinfo3
-rw-r--r--science/py-liac-arff/pkg-descr11
3 files changed, 36 insertions, 0 deletions
diff --git a/science/py-liac-arff/Makefile b/science/py-liac-arff/Makefile
new file mode 100644
index 000000000000..523d64cda934
--- /dev/null
+++ b/science/py-liac-arff/Makefile
@@ -0,0 +1,22 @@
+# Created by: Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= liac-arff
+PORTVERSION= 2.4.0
+CATEGORIES= science python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Read and write ARFF files in Python
+
+LICENSE= MIT
+
+TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}mock>=0:devel/py-mock@${PY_FLAVOR}
+
+USES= python
+USE_PYTHON= autoplist concurrent distutils
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/science/py-liac-arff/distinfo b/science/py-liac-arff/distinfo
new file mode 100644
index 000000000000..9b7f8d674565
--- /dev/null
+++ b/science/py-liac-arff/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1588213123
+SHA256 (liac-arff-2.4.0.tar.gz) = 47afcd1fd248b2892f66075987422d0576fc2c2fd0811d0cbd32f2135b065df5
+SIZE (liac-arff-2.4.0.tar.gz) = 15276
diff --git a/science/py-liac-arff/pkg-descr b/science/py-liac-arff/pkg-descr
new file mode 100644
index 000000000000..111357954ef6
--- /dev/null
+++ b/science/py-liac-arff/pkg-descr
@@ -0,0 +1,11 @@
+The liac-arff module implements functions to read and write ARFF files in
+Python. It was created in the Connectionist Artificial Intelligence Laboratory
+(LIAC), which takes place at the Federal University of Rio Grande do Sul
+(UFRGS), in Brazil.
+
+ARFF (Attribute-Relation File Format) is an file format specially created for
+describe datasets which are used commonly for machine learning experiments and
+softwares. This file format was created to be used in Weka, the best
+representative software for machine learning automated experiments.
+
+WWW: https://github.com/renatopp/liac-arff