aboutsummaryrefslogtreecommitdiff
path: root/science/py-lifelines
diff options
context:
space:
mode:
authorRuslan Makhmatkhanov <rm@FreeBSD.org>2018-11-13 18:35:02 +0000
committerRuslan Makhmatkhanov <rm@FreeBSD.org>2018-11-13 18:35:02 +0000
commit15c1b86206e403c9db691dad703989b182550805 (patch)
tree2956f7e2e9f00d33ba93ac0c901368904646bf5d /science/py-lifelines
parent17a4766068eaeee0a451cb0d77609b91076f4166 (diff)
downloadports-15c1b86206e403c9db691dad703989b182550805.tar.gz
ports-15c1b86206e403c9db691dad703989b182550805.zip
Survival analysis in Python, including Kaplan Meier, Nelson Aalen and regression
Notes
Notes: svn path=/head/; revision=484893
Diffstat (limited to 'science/py-lifelines')
-rw-r--r--science/py-lifelines/Makefile23
-rw-r--r--science/py-lifelines/distinfo3
-rw-r--r--science/py-lifelines/pkg-descr3
3 files changed, 29 insertions, 0 deletions
diff --git a/science/py-lifelines/Makefile b/science/py-lifelines/Makefile
new file mode 100644
index 000000000000..6335afbe3aaa
--- /dev/null
+++ b/science/py-lifelines/Makefile
@@ -0,0 +1,23 @@
+# $FreeBSD$
+
+PORTNAME= lifelines
+DISTVERSION= 0.14.6
+CATEGORIES= science python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= rm@FreeBSD.org
+COMMENT= Survival analysis in Python
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= ${PYNUMPY} \
+ ${PYTHON_PKGNAMEPREFIX}pandas>=0.18:math/py-pandas@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}scipy>0:science/py-scipy@${PY_FLAVOR}
+
+NO_ARCH= yes
+USES= python
+USE_PYTHON= autoplist distutils
+
+.include <bsd.port.mk>
diff --git a/science/py-lifelines/distinfo b/science/py-lifelines/distinfo
new file mode 100644
index 000000000000..1cd816a5325f
--- /dev/null
+++ b/science/py-lifelines/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1542010887
+SHA256 (lifelines-0.14.6.tar.gz) = 4c397debd434d5411497adf413fd68daece02fad0630c95f8d4229fb4cf3aa78
+SIZE (lifelines-0.14.6.tar.gz) = 1216910
diff --git a/science/py-lifelines/pkg-descr b/science/py-lifelines/pkg-descr
new file mode 100644
index 000000000000..eeacadedf776
--- /dev/null
+++ b/science/py-lifelines/pkg-descr
@@ -0,0 +1,3 @@
+Survival analysis in Python, including Kaplan Meier, Nelson Aalen and regression
+
+WWW: https://github.com/CamDavidsonPilon/lifelines/