aboutsummaryrefslogtreecommitdiff
path: root/science/py-mmtf-python
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2018-05-13 17:14:13 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2018-05-13 17:14:13 +0000
commit653f6281478b6938d4f6ce25ad193e562cc56fbb (patch)
tree0f1e7739d43b637cb0537c16c467da55b5f69be5 /science/py-mmtf-python
parentf1cdc0e64ded21db23978e002c9fcfa8fbd04d97 (diff)
downloadports-653f6281478b6938d4f6ce25ad193e562cc56fbb.tar.gz
ports-653f6281478b6938d4f6ce25ad193e562cc56fbb.zip
New port: science/py-mmtf-python: MMTF (Macromolecular Transmission Format) Python API
Notes
Notes: svn path=/head/; revision=469806
Diffstat (limited to 'science/py-mmtf-python')
-rw-r--r--science/py-mmtf-python/Makefile29
-rw-r--r--science/py-mmtf-python/distinfo3
-rw-r--r--science/py-mmtf-python/pkg-descr6
3 files changed, 38 insertions, 0 deletions
diff --git a/science/py-mmtf-python/Makefile b/science/py-mmtf-python/Makefile
new file mode 100644
index 000000000000..a220342c0351
--- /dev/null
+++ b/science/py-mmtf-python/Makefile
@@ -0,0 +1,29 @@
+# $FreeBSD$
+
+PORTNAME= mmtf-python
+DISTVERSIONPREFIX= v
+DISTVERSION= 1.1.0
+CATEGORIES= science python
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= MMTF (Macromolecular Transmission Format) Python API
+
+LICENSE= APACHE20
+LICENSE_FILE= ${WRKSRC}/LICENSE.txt
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}msgpack>0:devel/py-msgpack@${FLAVOR}
+
+USES= python
+USE_GITHUB= yes
+GH_ACCOUNT= rcsb
+USE_PYTHON= distutils autoplist
+NO_ARCH= yes
+
+post-build:
+ @${RM} ${STAGEDIR}${PREFIX}/bin/sample
+
+post-plist:
+ @${REINPLACE_CMD} -e '|bin/sample|d' ${TMPPLIST}
+
+.include <bsd.port.mk>
diff --git a/science/py-mmtf-python/distinfo b/science/py-mmtf-python/distinfo
new file mode 100644
index 000000000000..98c0b80168ff
--- /dev/null
+++ b/science/py-mmtf-python/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1526230432
+SHA256 (rcsb-mmtf-python-v1.1.0_GH0.tar.gz) = de2cc1692209e560002e11236070d5978a2db2faaaafa16371542b8fbd98ecac
+SIZE (rcsb-mmtf-python-v1.1.0_GH0.tar.gz) = 47054
diff --git a/science/py-mmtf-python/pkg-descr b/science/py-mmtf-python/pkg-descr
new file mode 100644
index 000000000000..6620b88af031
--- /dev/null
+++ b/science/py-mmtf-python/pkg-descr
@@ -0,0 +1,6 @@
+The python implementation of the MMTF API, decoder and encoder.
+
+The macromolecular transmission format (MMTF) is a binary encoding
+of biological structures.
+
+WWW: https://github.com/rcsb/mmtf-python