aboutsummaryrefslogtreecommitdiff
path: root/science/py-pysal/Makefile
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2021-08-08 14:36:56 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2021-08-08 14:54:11 +0000
commitdd6cd778b430f47d984976590a4b4e6857f3ecc6 (patch)
treeae9debbe1ddc06bcfe38e808c359c10f460094db /science/py-pysal/Makefile
parent5f187c0bb141fdf95ef70baf110446bf1a2da7d8 (diff)
downloadports-dd6cd778b430f47d984976590a4b4e6857f3ecc6.tar.gz
ports-dd6cd778b430f47d984976590a4b4e6857f3ecc6.zip
Diffstat (limited to 'science/py-pysal/Makefile')
-rw-r--r--science/py-pysal/Makefile27
1 files changed, 14 insertions, 13 deletions
diff --git a/science/py-pysal/Makefile b/science/py-pysal/Makefile
index c75512a7725c..a5d44dfd8db7 100644
--- a/science/py-pysal/Makefile
+++ b/science/py-pysal/Makefile
@@ -1,7 +1,7 @@
# Created by: Sunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>
PORTNAME= pysal
-PORTVERSION= 2.3.0
+PORTVERSION= 2.4.0
CATEGORIES= science python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -12,24 +12,25 @@ COMMENT= Cross-platform library of spatial analysis functions
LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE.txt
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}access>=1.1.1:science/py-access@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}esda>=2.3.1:science/py-esda@${PY_FLAVOR} \
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}access>=1.1.3:science/py-access@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}esda>=2.3.6:science/py-esda@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}giddy>=2.3.3:graphics/py-giddy@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}inequality>=1.0.0:science/py-inequality@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}libpysal>=4.3.0:science/py-libpysal@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}mapclassify>=2.3.0:graphics/py-mapclassify@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}mgwr>=2.1.1:graphics/py-mgwr@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}libpysal>=4.4.0:science/py-libpysal@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}mapclassify>=2.4.2:graphics/py-mapclassify@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}mgwr>=2.1.2:graphics/py-mgwr@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}pointpats>=2.2.0:graphics/py-pointpats@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}dateutil>=0:devel/py-dateutil@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}segregation>=1.3.0:science/py-segregation@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}spaghetti>=1.5.0:science/py-spaghetti@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}spglm>=1.0.7:math/py-spglm@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}spint>=1.0.6:math/py-spint@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}segregation>=1.5.0:science/py-segregation@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}spaghetti>=1.5.6:science/py-spaghetti@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}spglm>=1.0.8:math/py-spglm@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}spint>=1.0.7:math/py-spint@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}splot>=1.1.3:math/py-splot@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}spreg>=1.1.1:math/py-spreg@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}spopt>=0.1.1:math/py-spopt@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}spreg>=1.2.2:math/py-spreg@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}spvcm>=0.3.0:math/py-spvcm@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}tobler>=0.3.1:science/py-tobler@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}urllib3>=0,1:net/py-urllib3@${PY_FLAVOR}
+ ${PYTHON_PKGNAMEPREFIX}tobler>=0.6.0:science/py-tobler@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}urllib3>=1.26,1:net/py-urllib3@${PY_FLAVOR}
USES= python:3.7+
USE_PYTHON= autoplist concurrent distutils