aboutsummaryrefslogtreecommitdiff
path: root/science/py-pysal/Makefile
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2014-09-04 16:24:31 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2014-09-04 16:24:31 +0000
commite797e9b346ed58f6db82421a3f10c10ac8716db3 (patch)
treedc23b5681a8be40e6a995f27f81bffbfe15e3add /science/py-pysal/Makefile
parentd7e7bddf1e65ccc6e9a342918028b0e9c5d43125 (diff)
downloadports-e797e9b346ed58f6db82421a3f10c10ac8716db3.tar.gz
ports-e797e9b346ed58f6db82421a3f10c10ac8716db3.zip
Notes
Diffstat (limited to 'science/py-pysal/Makefile')
-rw-r--r--science/py-pysal/Makefile23
1 files changed, 23 insertions, 0 deletions
diff --git a/science/py-pysal/Makefile b/science/py-pysal/Makefile
new file mode 100644
index 000000000000..f2bf6f3d1c82
--- /dev/null
+++ b/science/py-pysal/Makefile
@@ -0,0 +1,23 @@
+# Created by: Sunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= pysal
+PORTVERSION= 1.8.0
+CATEGORIES= science python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= PySAL-${PORTVERSION}
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Cross-platform library of spatial analysis functions
+
+LICENSE= BSD3CLAUSE
+
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}numpy>=1.3:${PORTSDIR}/math/py-numpy \
+ ${PYTHON_PKGNAMEPREFIX}scipy>=0.7:${PORTSDIR}/science/py-scipy
+RUN_DEPENDS:= ${BUILD_DEPENDS}
+
+USE_PYTHON= autoplist distutils
+USES= python:2
+
+.include <bsd.port.mk>