aboutsummaryrefslogtreecommitdiff
path: root/science/py-pyteomics
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2021-05-10 20:06:35 +0000
committerThierry Thomas <thierry@FreeBSD.org>2021-05-10 20:13:20 +0000
commit1d44af58980136b882d146f21d8776943a14c5eb (patch)
treef3a678f8aea7c2044c105d15a6ff7c7afec40762 /science/py-pyteomics
parentaea041f3a2b531c0265897f6aec59936a96a9f35 (diff)
downloadports-1d44af58980136b882d146f21d8776943a14c5eb.tar.gz
ports-1d44af58980136b882d146f21d8776943a14c5eb.zip
math/py-matplotlib: chase minimum Python version in dependent ports
Since the previous update changed USES=python from 3.6+ to 3.7+, all dependent ports must have USES=python:3.7+ as well, otherwise it breaks the @py36 flavor. PR: 255347 Reported by: sunpoet
Diffstat (limited to 'science/py-pyteomics')
-rw-r--r--science/py-pyteomics/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/science/py-pyteomics/Makefile b/science/py-pyteomics/Makefile
index 187d7c5d0518..b9edb37e43b4 100644
--- a/science/py-pyteomics/Makefile
+++ b/science/py-pyteomics/Makefile
@@ -9,7 +9,7 @@ COMMENT= Python modules for proteomics data analysis
LICENSE= APACHE20
-USES= python:3.6+
+USES= python:3.7+
USE_PYTHON= autoplist concurrent distutils
NO_ARCH= yes
@@ -20,7 +20,7 @@ DF_DESC= DataFrame support
GRAPHICS_DESC= Graphics support
TDA_DESC= Target-decoy approach support
UNIMOD_DESC= Unimod database support
-XML_DESC= XML support
+XML_DESC= XML support
DF_RUN_DEPENDS= ${PY_PANDAS}
GRAPHICS_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}matplotlib>=0:math/py-matplotlib@${PY_FLAVOR}