aboutsummaryrefslogtreecommitdiff
path: root/science/py-quantities
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2018-03-29 20:37:39 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2018-03-29 20:37:39 +0000
commit2ba5005caa744a8eef80135cdfdbf215c0173f94 (patch)
treefa5ed165afa618cf413362b7bf5aea9b850154f4 /science/py-quantities
parent36c66c1b394a36073185e812f5867c6be5521da1 (diff)
downloadports-2ba5005caa744a8eef80135cdfdbf215c0173f94.tar.gz
ports-2ba5005caa744a8eef80135cdfdbf215c0173f94.zip
Notes
Diffstat (limited to 'science/py-quantities')
-rw-r--r--science/py-quantities/Makefile20
-rw-r--r--science/py-quantities/distinfo3
-rw-r--r--science/py-quantities/pkg-descr9
3 files changed, 32 insertions, 0 deletions
diff --git a/science/py-quantities/Makefile b/science/py-quantities/Makefile
new file mode 100644
index 000000000000..e097401be8b1
--- /dev/null
+++ b/science/py-quantities/Makefile
@@ -0,0 +1,20 @@
+# $FreeBSD$
+
+PORTNAME= quantities
+DISTVERSION= 0.12.1
+CATEGORIES= science python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Support for physical quantities with units, based on numpy
+
+LICENSE= BSD3CLAUSE
+
+RUN_DEPENDS= ${PYNUMPY}
+
+USES= python
+USE_PYTHON= distutils autoplist
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/science/py-quantities/distinfo b/science/py-quantities/distinfo
new file mode 100644
index 000000000000..284c41d09d24
--- /dev/null
+++ b/science/py-quantities/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1522354862
+SHA256 (quantities-0.12.1.tar.gz) = 0a03e8511db603c57ca80dee851c43f08d0457f4d592bcac2e154570756cb934
+SIZE (quantities-0.12.1.tar.gz) = 81763
diff --git a/science/py-quantities/pkg-descr b/science/py-quantities/pkg-descr
new file mode 100644
index 000000000000..4753f167f583
--- /dev/null
+++ b/science/py-quantities/pkg-descr
@@ -0,0 +1,9 @@
+Quantities is designed to handle arithmetic and conversions of physical
+quantities, which have a magnitude, dimensionality specified by various units,
+and possibly an uncertainty. See the tutorial for examples. Quantities builds
+on the popular numpy library and is designed to work with numpy ufuncs, many
+of which are already supported. Quantities is actively developed, and while
+the current features and API are stable, test coverage is incomplete so the
+package is not suggested for mission-critical applications.
+
+WWW: https://github.com/python-quantities/python-quantities