aboutsummaryrefslogtreecommitdiff
path: root/science/py-scipy
diff options
context:
space:
mode:
authorTobias Kortkamp <tobik@FreeBSD.org>2020-07-05 11:02:17 +0000
committerTobias Kortkamp <tobik@FreeBSD.org>2020-07-05 11:02:17 +0000
commit8f326d1f653d5049301ed564a014fc6254dfa2e5 (patch)
treeac7a69976a2f5f950c6a718ec903cec64a848c41 /science/py-scipy
parentb54c8b8e3e58ce1f60449a2680c454a3ba3cf0bc (diff)
downloadports-8f326d1f653d5049301ed564a014fc6254dfa2e5.tar.gz
ports-8f326d1f653d5049301ed564a014fc6254dfa2e5.zip
science/py-scipy: Unbreak build with GCC 10
scipy/sparse/linalg/eigen/arpack/ARPACK/SRC/cnaitr.f:666:35: 383 | call svout (logfil, 1, rnorm, ndigit, | 2 ...... 666 | call svout (logfil, 2, rtemp, ndigit, | 1 Error: Rank mismatch between actual argument at (1) and actual argument at (2) (scalar and rank-1) scipy/sparse/linalg/eigen/arpack/ARPACK/SRC/cnaitr.f:737:39: 383 | call svout (logfil, 1, rnorm, ndigit, | 2 ...... 737 | call svout (logfil, 2, rtemp, ndigit, | 1 Error: Rank mismatch between actual argument at (1) and actual argument at (2) (scalar and rank-1) gfortran10:f77: scipy/sparse/linalg/eigen/arpack/ARPACK/SRC/dsesrt.f scipy/sparse/linalg/eigen/arpack/ARPACK/SRC/dsaitr.f:671:35: 369 | call dvout (logfil, 1, rnorm, ndigit, | 2 ...... 671 | call dvout (logfil, 2, xtemp, ndigit, | 1 Error: Rank mismatch between actual argument at (1) and actual argument at (2) (scalar and rank-1) scipy/sparse/linalg/eigen/arpack/ARPACK/SRC/dsaitr.f:743:39: 369 | call dvout (logfil, 1, rnorm, ndigit, | 2 ...... 743 | call dvout (logfil, 2, xtemp, ndigit, | 1 Error: Rank mismatch between actual argument at (1) and actual argument at (2) (scalar and rank-1) http://package18.nyi.freebsd.org/data/121amd64-default-PR244494/2020-06-10_18h04m44s/logs/errors/py27-scipy-1.2.2_1.log http://package18.nyi.freebsd.org/data/121amd64-default-PR244494/2020-06-10_18h04m44s/logs/errors/py37-scipy-1.2.2_1.log A better fix would be to update this port to >= 1.5.1 which should support GCC 10 out of the box and would allow -std=legacy to be removed again. PR: 246700
Notes
Notes: svn path=/head/; revision=541273
Diffstat (limited to 'science/py-scipy')
-rw-r--r--science/py-scipy/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/science/py-scipy/Makefile b/science/py-scipy/Makefile
index a3f3474918e6..a80509802590 100644
--- a/science/py-scipy/Makefile
+++ b/science/py-scipy/Makefile
@@ -25,6 +25,7 @@ RUN_DEPENDS= ${PYNUMPY}
USES= fortran python shebangfix
USE_PYTHON= autoplist concurrent distutils
+FFLAGS+= -std=legacy
LDFLAGS+= -shared
PYDISTUTILS_BUILDARGS= --fcompiler=gnu95
PYDISTUTILS_CONFIGUREARGS= --fcompiler=gnu95