aboutsummaryrefslogtreecommitdiff
path: root/science/py-scipy
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2020-12-25 05:41:53 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2020-12-25 05:41:53 +0000
commitc923a168c9ca5e26ddc7f86aafe905b9c9de09a6 (patch)
tree22c9787e5a094d69ba13a36370d737c44ca3c84c /science/py-scipy
parente6c4a87776a74c98216cdf81d3ce13d54bafeb7a (diff)
downloadports-c923a168c9ca5e26ddc7f86aafe905b9c9de09a6.tar.gz
ports-c923a168c9ca5e26ddc7f86aafe905b9c9de09a6.zip
science/py-scipy: Remove the recently added USES=blaslapack:openblas because LIB_DEPENDS=libblas.so:math/blas provides blas
It does build with libblas.so:math/blas, but doesn't with blaslapack:openblas. PR: 251718 Reported by: thierry Approved by: python (correction of the previous recent commit r559036)
Notes
Notes: svn path=/head/; revision=559210
Diffstat (limited to 'science/py-scipy')
-rw-r--r--science/py-scipy/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/science/py-scipy/Makefile b/science/py-scipy/Makefile
index a8f17bcfd2c2..592172917310 100644
--- a/science/py-scipy/Makefile
+++ b/science/py-scipy/Makefile
@@ -3,6 +3,7 @@
PORTNAME= scipy
DISTVERSION= 1.5.4
+PORTREVISION= 1
CATEGORIES= science python
MASTER_SITES= https://docs.scipy.org/doc/scipy-${PORTVERSION:R}.1/:doc \
CHEESESHOP:source \
@@ -24,7 +25,7 @@ BUILD_DEPENDS= ${PYNUMPY} \
LIB_DEPENDS= libblas.so:math/blas
RUN_DEPENDS= ${PYNUMPY}
-USES= blaslapack:openblas fortran python:3.6+ shebangfix
+USES= fortran python:3.6+ shebangfix
USE_PYTHON= autoplist concurrent distutils
FFLAGS+= -std=legacy