aboutsummaryrefslogtreecommitdiff
path: root/science/py-segregation
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2021-01-03 19:58:14 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2021-01-03 19:58:14 +0000
commitf013c58ddaf69754b4eec58298a4fa6caa704f15 (patch)
tree8fdc38ff96a530a96ec25a0e24e9fead909af892 /science/py-segregation
parentc917dfab31a0888bab1860150a3a32434fc7b67b (diff)
downloadports-f013c58ddaf69754b4eec58298a4fa6caa704f15.tar.gz
ports-f013c58ddaf69754b4eec58298a4fa6caa704f15.zip
Add py-segregation 1.4.0
Segregation Analysis, Inference, and Decomposition with PySAL The PySAL segregation package is a tool for analyzing patterns of urban segregation. With only a few lines of code, segregation users can calculate over 40 segregation measures from simple to state-of-the art. WWW: https://pysal.org/segregation/ WWW: https://github.com/pysal/segregation
Notes
Notes: svn path=/head/; revision=560054
Diffstat (limited to 'science/py-segregation')
-rw-r--r--science/py-segregation/Makefile32
-rw-r--r--science/py-segregation/distinfo3
-rw-r--r--science/py-segregation/pkg-descr8
3 files changed, 43 insertions, 0 deletions
diff --git a/science/py-segregation/Makefile b/science/py-segregation/Makefile
new file mode 100644
index 000000000000..db04f4a8e709
--- /dev/null
+++ b/science/py-segregation/Makefile
@@ -0,0 +1,32 @@
+# Created by: Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= segregation
+PORTVERSION= 1.4.0
+CATEGORIES= science python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Analytics for spatial and non-spatial segregation in Python
+
+LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE.txt
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}geopandas>=0:graphics/py-geopandas@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}libpysal>=0:science/py-libpysal@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}mapclassify>=0:graphics/py-mapclassify@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}matplotlib>=0:math/py-matplotlib@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}numpy>=0,1:math/py-numpy@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pandas>=0,1:math/py-pandas@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}scikit-learn>=0.21.3:science/py-scikit-learn@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}scipy>=0:science/py-scipy@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}seaborn>=0:math/py-seaborn@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}tqdm>=0:misc/py-tqdm@${PY_FLAVOR}
+
+USES= python:3.6+
+USE_PYTHON= autoplist concurrent distutils
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/science/py-segregation/distinfo b/science/py-segregation/distinfo
new file mode 100644
index 000000000000..df9ea092d1dc
--- /dev/null
+++ b/science/py-segregation/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1609598763
+SHA256 (segregation-1.4.0.tar.gz) = 9e0cf8929b3005758ec157adf4fcd6ebffc494b62a81489cbfb3d0f3ca6b2224
+SIZE (segregation-1.4.0.tar.gz) = 62224
diff --git a/science/py-segregation/pkg-descr b/science/py-segregation/pkg-descr
new file mode 100644
index 000000000000..1a184877f74c
--- /dev/null
+++ b/science/py-segregation/pkg-descr
@@ -0,0 +1,8 @@
+Segregation Analysis, Inference, and Decomposition with PySAL
+
+The PySAL segregation package is a tool for analyzing patterns of urban
+segregation. With only a few lines of code, segregation users can calculate over
+40 segregation measures from simple to state-of-the art.
+
+WWW: https://pysal.org/segregation/
+WWW: https://github.com/pysal/segregation