aboutsummaryrefslogtreecommitdiff
path: root/science/py-veusz
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2019-03-17 20:32:18 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2019-03-17 20:32:18 +0000
commitce30afb6309e9ee5aa4e0124a0fa8ebf3cb790b9 (patch)
tree74cebf4aeaf8610fa71f2f14c4eed8ccf9b492cd /science/py-veusz
parentc743c17be88d707a59b21bcde39a9e2b271c2972 (diff)
downloadports-ce30afb6309e9ee5aa4e0124a0fa8ebf3cb790b9.tar.gz
ports-ce30afb6309e9ee5aa4e0124a0fa8ebf3cb790b9.zip
Re-add science/py-veusz: the latest version builds with Qt5
Notes
Notes: svn path=/head/; revision=496106
Diffstat (limited to 'science/py-veusz')
-rw-r--r--science/py-veusz/Makefile28
-rw-r--r--science/py-veusz/distinfo3
-rw-r--r--science/py-veusz/files/patch-pyqtdistutils.py11
-rw-r--r--science/py-veusz/pkg-descr9
4 files changed, 51 insertions, 0 deletions
diff --git a/science/py-veusz/Makefile b/science/py-veusz/Makefile
new file mode 100644
index 000000000000..8bf5d567183a
--- /dev/null
+++ b/science/py-veusz/Makefile
@@ -0,0 +1,28 @@
+# Created by: Stas Timokhin <devel@stasyan.com>
+# $FreeBSD$
+
+PORTNAME= veusz
+DISTVERSIONPREFIX= ${PORTNAME}-
+DISTVERSION= 3.0.1
+CATEGORIES= science kde
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Scientific plotting package
+
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+BUILD_DEPENDS= ${RUN_DEPENDS}
+RUN_DEPENDS= ${PYNUMPY}
+
+USES= python:3.5+ pyqt:5 qt:5 shebangfix
+USE_GITHUB= yes
+USE_PYQT= core gui svg
+USE_PYTHON= distutils concurrent autoplist
+USE_QT= core gui xml widgets qmake_build
+SHEBANG_FILES= examples/embedexample.py
+
+MAKE_ENV= SIP_DIR=${LOCALBASE}/share/PyQt5/${PYTHON_VER}/sip
+
+.include <bsd.port.mk>
diff --git a/science/py-veusz/distinfo b/science/py-veusz/distinfo
new file mode 100644
index 000000000000..3887296651d5
--- /dev/null
+++ b/science/py-veusz/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1544078906
+SHA256 (veusz-veusz-veusz-3.0.1_GH0.tar.gz) = 76f4feb400be4ada538e832cce352211383dbdb530f41f379c9dbf28e3591db3
+SIZE (veusz-veusz-veusz-3.0.1_GH0.tar.gz) = 1706700
diff --git a/science/py-veusz/files/patch-pyqtdistutils.py b/science/py-veusz/files/patch-pyqtdistutils.py
new file mode 100644
index 000000000000..7e512cfa5a7d
--- /dev/null
+++ b/science/py-veusz/files/patch-pyqtdistutils.py
@@ -0,0 +1,11 @@
+--- pyqtdistutils.py.orig 2019-03-17 19:30:42 UTC
++++ pyqtdistutils.py
+@@ -272,7 +272,7 @@ class build_ext(distutils.command.build_
+ sip_exe,
+ '-c', self.build_temp
+ ] + SIP_FLAGS.split() + [
+- '-I', os.path.join(sip_dir, 'PyQt5'),
++ '-I', sip_dir, # for FreeBSD's SIP file locations
+ '-b', sbf,
+ source
+ ]
diff --git a/science/py-veusz/pkg-descr b/science/py-veusz/pkg-descr
new file mode 100644
index 000000000000..0a3a8a934a5b
--- /dev/null
+++ b/science/py-veusz/pkg-descr
@@ -0,0 +1,9 @@
+Veusz is a GUI scientific plotting and graphing package. It
+is designed to produce publication-ready Postscript or PDF
+output. SVG, EMF and bitmap formats export are also supported.
+The program runs under Unix/Linux, Windows or Mac OS X, and
+binaries are provided. Data can be read from text, CSV or FITS
+files, and data can be manipulated or examined from within the
+application.
+
+WWW: http://home.gna.org/veusz/