aboutsummaryrefslogtreecommitdiff
path: root/science/pycdf/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-06-03 09:41:36 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-06-03 09:41:36 +0000
commitee2016f4e0c358f47280f662dae74d251ef0e3f9 (patch)
tree12dc2c4c22a40951305b13dd4c920d576452753a /science/pycdf/Makefile
parent761268e09eb0e4dded2803412b2f9ac71251dc9f (diff)
Notes
Diffstat (limited to 'science/pycdf/Makefile')
-rw-r--r--science/pycdf/Makefile30
1 files changed, 30 insertions, 0 deletions
diff --git a/science/pycdf/Makefile b/science/pycdf/Makefile
new file mode 100644
index 000000000000..2dd5cc6e74da
--- /dev/null
+++ b/science/pycdf/Makefile
@@ -0,0 +1,30 @@
+# Ports collection makefile for: pycdf
+# Date created: 30 April, 2008
+# Whom: wenheping@gmail.com
+#
+# $FreeBSD$
+#
+
+PORTNAME= pycdf
+PORTVERSION= 0.6.3
+CATEGORIES= science python
+MASTER_SITES= SF
+MASTER_SITE_SUBDIR= pysclint
+DISTNAME= ${PORTNAME}-0.6-3b
+
+MAINTAINER= wenheping@gmail.com
+COMMENT= A Python Interface to the Unidata NetCDF Library
+
+BUILD_DEPENDS= ${PYTHON_SITELIBDIR}/numpy:${PORTSDIR}/math/py-numpy \
+ ${LOCALBASE}/lib/libnetcdf.so:${PORTSDIR}/science/netcdf
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+LDFLAGS= "-L${LOCALBASE}/lib"
+
+USE_PYTHON= 2.5+
+USE_PYDISTUTILS= yes
+PYTHON_PKGNAMEPREFIX= yes
+PYDISTUTILS_EGGINFO= pycdf-0.6_3b-py${PYTHON_VER}.egg-info
+WRKSRC= ${WRKDIR}/${DISTNAME}
+
+.include <bsd.port.mk>