aboutsummaryrefslogtreecommitdiff
path: root/science/qmcpack
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2018-08-20 07:44:54 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2018-08-20 07:44:54 +0000
commitf98320e38d5a4239aba8346c0d9494b205d1aea5 (patch)
treee2eb57ea10ff0d2660866a46925dd6bfde89b125 /science/qmcpack
parentacda4f6416c8d33171725bb9e66512f40353c769 (diff)
downloadports-f98320e38d5a4239aba8346c0d9494b205d1aea5.tar.gz
ports-f98320e38d5a4239aba8346c0d9494b205d1aea5.zip
New port: science/qmcpack: Many-body ab initio Quantum Monte Carlo code for quantum chemstry
Notes
Notes: svn path=/head/; revision=477634
Diffstat (limited to 'science/qmcpack')
-rw-r--r--science/qmcpack/Makefile35
-rw-r--r--science/qmcpack/distinfo3
-rw-r--r--science/qmcpack/files/patch-CMakeLists.txt20
-rw-r--r--science/qmcpack/pkg-descr13
4 files changed, 71 insertions, 0 deletions
diff --git a/science/qmcpack/Makefile b/science/qmcpack/Makefile
new file mode 100644
index 000000000000..ba32002f0d1b
--- /dev/null
+++ b/science/qmcpack/Makefile
@@ -0,0 +1,35 @@
+# $FreeBSD$
+
+PORTNAME= qmcpack
+DISTVERSIONPREFIX= v
+DISTVERSION= 3.5.0
+CATEGORIES= science
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Many-body ab initio Quantum Monte Carlo code for quantum chemstry
+
+LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+LIB_DEPENDS= libboost_system.so:devel/boost-libs \
+ libfftw3.so:math/fftw3 \
+ libhdf5.so:science/hdf5 \
+ libmpich.so:net/mpich2 \
+ libomp.so:devel/openmp \
+ libopenblas.so:math/openblas \
+ libsz.so:science/szip
+
+USES= cmake:outsource compiler:c++11-lang fortran localbase:ldflags pkgconfig
+USE_GITHUB= yes
+GH_ACCOUNT= ${PORTNAME:tu}
+USE_GNOME= libxml2
+
+PROGS= convert4qmc extract-eshdf-kvectors getSupercell qmcpack
+PLIST_FILES= ${PROGS:C/^/bin\//}
+
+do-install:
+.for p in ${PROGS}
+ ${INSTALL_PROGRAM} ${BUILD_WRKSRC}/bin/${p} ${STAGEDIR}${PREFIX}/bin
+.endfor
+
+.include <bsd.port.mk>
diff --git a/science/qmcpack/distinfo b/science/qmcpack/distinfo
new file mode 100644
index 000000000000..d0cfe20b9fad
--- /dev/null
+++ b/science/qmcpack/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1534746662
+SHA256 (QMCPACK-qmcpack-v3.5.0_GH0.tar.gz) = 5e107bcf39df8cd04ec1cf647394937ea4881dbac76129c256a4409179ead138
+SIZE (QMCPACK-qmcpack-v3.5.0_GH0.tar.gz) = 90264770
diff --git a/science/qmcpack/files/patch-CMakeLists.txt b/science/qmcpack/files/patch-CMakeLists.txt
new file mode 100644
index 000000000000..1492aca85efe
--- /dev/null
+++ b/science/qmcpack/files/patch-CMakeLists.txt
@@ -0,0 +1,20 @@
+--- CMakeLists.txt.orig 2018-08-01 22:48:30 UTC
++++ CMakeLists.txt
+@@ -174,7 +174,7 @@ CHECK_INCLUDE_FILE(unistd.h HAVE_UNISTD_
+ # MPIP_PROFILE profile mpi performance
+ ######################################################################
+ SET(QMC_ADIOS 0 CACHE BOOL "Build with ADIOS")
+-SET(BUILD_UNIT_TESTS 1 CACHE BOOL "Build unit tests")
++SET(BUILD_UNIT_TESTS 0 CACHE BOOL "Build unit tests")
+ SET(BUILD_SANDBOX 1 CACHE BOOL "Build sandbox tests and miniapps")
+ SET(BUILD_LMYENGINE_INTERFACE 1 CACHE BOOL "Build LMY engine")
+ IF (QMC_CUDA AND BUILD_LMYENGINE_INTERFACE)
+@@ -909,7 +909,7 @@ ENDIF(QMC_ADIOS)
+
+ SUBDIRS(src)
+
+-IF(NOT(QMC_BUILD_LEVEL GREATER 4))
++IF(FALSE AND NOT(QMC_BUILD_LEVEL GREATER 4))
+ SUBDIRS(tests)
+ SUBDIRS(examples)
+ IF(IS_DIRECTORY "${PROJECT_SOURCE_DIR}/nexus")
diff --git a/science/qmcpack/pkg-descr b/science/qmcpack/pkg-descr
new file mode 100644
index 000000000000..a1dff3c612b0
--- /dev/null
+++ b/science/qmcpack/pkg-descr
@@ -0,0 +1,13 @@
+QMCPACK is an open-source, high-performance electronic structure code that
+implements numerous Quantum Monte Carlo algorithms. Its main applications are
+electronic structure calculations of molecular, periodic 2D and periodic 3D
+solid-state systems. Variational Monte Carlo (VMC), diffusion Monte Carlo (DMC)
+and a number of other advanced QMC algorithms are implemented.
+
+By directly solving the Schrodinger equation, QMC methods offer greater accuracy
+than methods such as density functional theory, but at a trade-off of much
+greater computational expense. Distinct from many other correlated many-body
+methods, QMC methods are readily applicable to both bulk (periodic) and isolated
+molecular systems.
+
+WWW: https://www.qmcpack.org/