aboutsummaryrefslogtreecommitdiff
path: root/science/quantum-espresso-pseudopotentials
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2018-11-21 22:34:45 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2018-11-21 22:34:45 +0000
commit809de18e9d70f9bd7aab2ad717356af012f34585 (patch)
tree0b6ea275833836044f5c3071eafee6bb44e9de05 /science/quantum-espresso-pseudopotentials
parent3be675e8e41f6d537667872461ad2613b8faeabe (diff)
downloadports-809de18e9d70f9bd7aab2ad717356af012f34585.tar.gz
ports-809de18e9d70f9bd7aab2ad717356af012f34585.zip
New port: science/quantum-espresso-pseudopotentials: Pseudopotentials for use with Quantum Espresso
Notes
Notes: svn path=/head/; revision=485564
Diffstat (limited to 'science/quantum-espresso-pseudopotentials')
-rw-r--r--science/quantum-espresso-pseudopotentials/Makefile40
-rw-r--r--science/quantum-espresso-pseudopotentials/distinfo3
-rw-r--r--science/quantum-espresso-pseudopotentials/files/patch-make__ps11
-rw-r--r--science/quantum-espresso-pseudopotentials/files/patch-make__test11
-rw-r--r--science/quantum-espresso-pseudopotentials/pkg-descr9
5 files changed, 74 insertions, 0 deletions
diff --git a/science/quantum-espresso-pseudopotentials/Makefile b/science/quantum-espresso-pseudopotentials/Makefile
new file mode 100644
index 000000000000..fb7653ff4b4b
--- /dev/null
+++ b/science/quantum-espresso-pseudopotentials/Makefile
@@ -0,0 +1,40 @@
+# $FreeBSD$
+
+PORTNAME= quantum-espresso-pseudopotentials
+DISTVERSION= g20180406
+CATEGORIES= science
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Pseudopotentials for use with Quantum Espresso
+
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/License
+
+BUILD_DEPENDS= quantum-espresso>0:science/quantum-espresso \
+ bash:shells/bash
+RUN_DEPENDS= quantum-espresso>0:science/quantum-espresso
+
+USES= shebangfix
+SHEBANG_GLOB= *.job make_*
+SHEBANG_FILES= QE_path clean clean_all
+USE_GITHUB= yes
+GH_ACCOUNT= dalcorso
+GH_PROJECT= pslibrary
+GH_TAGNAME= 9dd5cf7
+
+NO_ARCH= yes
+
+DATADIR= ${PREFIX}/share/quantum-espresso
+PORTDATA= *
+
+post-patch:
+ @${REINPLACE_CMD} 's|/path_to_quantum_espresso/|${LOCALBASE}|' ${WRKSRC}/QE_path
+
+do-build:
+ @cd ${WRKSRC} && ./make_all_ps
+
+do-install:
+ ${MKDIR} ${STAGEDIR}${DATADIR}
+ ${FIND} ${WRKSRC} -name "*.UPF" -and -exec ${INSTALL_DATA} {} ${STAGEDIR}${DATADIR} \;
+
+.include <bsd.port.mk>
diff --git a/science/quantum-espresso-pseudopotentials/distinfo b/science/quantum-espresso-pseudopotentials/distinfo
new file mode 100644
index 000000000000..d48c8d9a6c06
--- /dev/null
+++ b/science/quantum-espresso-pseudopotentials/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1542825686
+SHA256 (dalcorso-pslibrary-g20180406-9dd5cf7_GH0.tar.gz) = 2c1d1f4a42511e86b10518b9061c6e4fc71fbd4c4c77b42eef3cfd2504d65124
+SIZE (dalcorso-pslibrary-g20180406-9dd5cf7_GH0.tar.gz) = 201444
diff --git a/science/quantum-espresso-pseudopotentials/files/patch-make__ps b/science/quantum-espresso-pseudopotentials/files/patch-make__ps
new file mode 100644
index 000000000000..17e2cd1c8caf
--- /dev/null
+++ b/science/quantum-espresso-pseudopotentials/files/patch-make__ps
@@ -0,0 +1,11 @@
+--- make_ps.orig 2018-11-21 18:54:56 UTC
++++ make_ps
+@@ -18,7 +18,7 @@ work=./WORK
+ # For QE < 5.0
+ #. $PWDIR/example/environment_variables
+ #
+-. $PWDIR/environment_variables
++#. $PWDIR/environment_variables
+ BIN_DIR=$PWDIR/bin
+
+ mkdir $work >& /dev/null
diff --git a/science/quantum-espresso-pseudopotentials/files/patch-make__test b/science/quantum-espresso-pseudopotentials/files/patch-make__test
new file mode 100644
index 000000000000..5ba08c2db777
--- /dev/null
+++ b/science/quantum-espresso-pseudopotentials/files/patch-make__test
@@ -0,0 +1,11 @@
+--- make_test.orig 2018-11-21 18:55:35 UTC
++++ make_test
+@@ -18,7 +18,7 @@ work=./TEST
+ # For QE < 5.0
+ #. $PWDIR/example/environment_variables
+ #
+-. $PWDIR/environment_variables
++#. $PWDIR/environment_variables
+ BIN_DIR=$PWDIR/bin
+
+ mkdir $work >& /dev/null
diff --git a/science/quantum-espresso-pseudopotentials/pkg-descr b/science/quantum-espresso-pseudopotentials/pkg-descr
new file mode 100644
index 000000000000..31fb29844afb
--- /dev/null
+++ b/science/quantum-espresso-pseudopotentials/pkg-descr
@@ -0,0 +1,9 @@
+quantum-espresso-pseudopotentials contains pseudopotentials that are
+normally needed in order to run quantum chemistry computations in
+the Quantum Espresso suite.
+
+Quantum Espresso is an integrated suite of open-source computer codes
+for electronic-structure calculations and materials modeling at the nanoscale.
+It is based on density-functional theory, plane waves, and pseudopotentials.
+
+WWW: https://www.quantum-espresso.org/