aboutsummaryrefslogtreecommitdiff
path: root/science/ruby-dcl
diff options
context:
space:
mode:
authorSteve Wills <swills@FreeBSD.org>2014-03-28 21:28:38 +0000
committerSteve Wills <swills@FreeBSD.org>2014-03-28 21:28:38 +0000
commit451a5a65ea2786ea432ed4802204edf5a6fe565e (patch)
tree860ca0407c879553615f0df8e45661340fd8e8a6 /science/ruby-dcl
parent7a069c6f581f1a2a942497d7bc3b637ae23699cc (diff)
downloadports-451a5a65ea2786ea432ed4802204edf5a6fe565e.tar.gz
ports-451a5a65ea2786ea432ed4802204edf5a6fe565e.zip
Notes
Diffstat (limited to 'science/ruby-dcl')
-rw-r--r--science/ruby-dcl/Makefile22
-rw-r--r--science/ruby-dcl/pkg-descr5
2 files changed, 13 insertions, 14 deletions
diff --git a/science/ruby-dcl/Makefile b/science/ruby-dcl/Makefile
index cd5340a5dc28..fe37d2f9c640 100644
--- a/science/ruby-dcl/Makefile
+++ b/science/ruby-dcl/Makefile
@@ -17,15 +17,18 @@ COMMENT= A Ruby interface to the scientific graphic library DCL
LICENSE= BSD
LICENSE_FILE= ${WRKSRC}/LICENSE.txt
-BUILD_DEPENDS= ${RUBY_SITEARCHLIBDIR}/narray.so:${PORTSDIR}/math/ruby-narray \
+BUILD_DEPENDS= rubygem-narray>=0.5.5:${PORTSDIR}/math/rubygem-narray \
${LOCALBASE}/lib/libcdcl.so:${PORTSDIR}/science/cdcl
RUN_DEPENDS= ${LOCALBASE}/lib/libcdcl.so:${PORTSDIR}/science/cdcl \
- ${RUBY_SITEARCHLIBDIR}/narray.so:${PORTSDIR}/math/ruby-narray \
- rubygem-gdk_pixbuf2>0:${PORTSDIR}/graphics/rubygem-gdk_pixbuf2 \
- rubygem-gtk2>0:${PORTSDIR}/x11-toolkits/rubygem-gtk2
+ rubygem-narray>=0.5.5:${PORTSDIR}/math/rubygem-narray \
+ rubygem-gdk_pixbuf2>=2.1.0:${PORTSDIR}/graphics/rubygem-gdk_pixbuf2 \
+ rubygem-gtk2>=2.1.0:${PORTSDIR}/x11-toolkits/rubygem-gtk2
USE_RUBY= yes
USE_RUBY_EXTCONF= yes
+RUBY_NARRAY_VERSION= `make -C ${PORTSDIR}/math/rubygem-narray -V PORTVERSION`
+RUBY_NARRAY_PKGNAME= narray-${RUBY_NARRAY_VERSION}
+CONFIGURE_ARGS+= --with-narray-include=${LOCALBASE}/lib/ruby/gems/${RUBY_VER}/gems/${RUBY_NARRAY_PKGNAME}/
DOCSDIR= ${RUBY_MODDOCDIR}
EXAMPLESDIR= ${RUBY_MODEXAMPLESDIR}
@@ -33,7 +36,6 @@ EXAMPLESDIR= ${RUBY_MODEXAMPLESDIR}
PORTDOCS= ChangeLog README ToDo
PORTEXAMPLES= *
-NO_STAGE= yes
.include <bsd.port.pre.mk>
.if ${ARCH} == "ia64"
@@ -42,13 +44,13 @@ BROKEN= Does not build on ${ARCH} (Needs to link against shared libraries)
post-install:
.if !defined(NOPORTEXAMPLES)
- ${MKDIR} ${RUBY_MODEXAMPLESDIR}
- (cd ${WRKSRC}/demo/ && ${COPYTREE_SHARE} \* ${RUBY_MODEXAMPLESDIR})
+ ${MKDIR} ${STAGEDIR}${RUBY_MODEXAMPLESDIR}
+ (cd ${WRKSRC}/demo/ && ${COPYTREE_SHARE} \* ${STAGEDIR}${RUBY_MODEXAMPLESDIR})
.endif
-.if !defined(NOPORTDOCS)
- ${MKDIR} ${RUBY_MODDOCDIR}
+.if !defined(PORT_OPTIONS:MDOCS)
+ ${MKDIR} ${STAGEDIR}${RUBY_MODDOCDIR}
.for f in ${PORTDOCS}
- ${INSTALL_DATA} ${WRKSRC}/${f} ${RUBY_MODDOCDIR}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${STAGEDIR}${RUBY_MODDOCDIR}
.endfor
.endif
diff --git a/science/ruby-dcl/pkg-descr b/science/ruby-dcl/pkg-descr
index b9a4c5a1ee72..236d7a6c9d35 100644
--- a/science/ruby-dcl/pkg-descr
+++ b/science/ruby-dcl/pkg-descr
@@ -1,6 +1,3 @@
This is a Ruby interface to the scientific graphic library DCL.
-Author: Takeshi Horinouchi <horinout _at_ ees.hokudai.ac.jp>
- & Dennou Ruby Project
-
-WWW: http://ruby.gfd-dennou.org/products/ruby-dcl/
+WWW: http://ruby.gfd-dennou.org/products/ruby-dcl/