aboutsummaryrefslogtreecommitdiff
path: root/science/rubygem-rgeo
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2018-04-07 16:32:18 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2018-04-07 16:32:18 +0000
commitbb0fe16f32f7a16ce44e6b21e78a7b8f1ddb2551 (patch)
tree2fb83bbf77c83aaed71c10f3a4320d69bf58e967 /science/rubygem-rgeo
parent5b431fc70d147d6c5a1aa6cbc13c5b367cfacb5d (diff)
downloadports-bb0fe16f32f7a16ce44e6b21e78a7b8f1ddb2551.tar.gz
ports-bb0fe16f32f7a16ce44e6b21e78a7b8f1ddb2551.zip
Add rubygem-rgeo 1.0.0
RGeo is a geospatial data library for Ruby. RGeo is a key component for writing location-aware applications in the Ruby programming language. At its core is an implementation of the industry standard OGC Simple Features Specification, which provides data representations of geometric objects such as points, lines, and polygons, along with a set of geometric analysis operations. This makes it ideal for modeling geolocation data. It also supports a suite of optional add-on modules that provide various geolocation-related services. Use the core rgeo gem to: - Represent spatial and geolocation data objects such as points, lines, and polygons in your Ruby application. - Perform standard spatial analysis operations such as finding intersections, creating buffers, and computing lengths and areas. - Correctly handle spherical geometry, and compute geographic projections for map display and data analysis. - Read and write location data in the WKT and WKB representations used by spatial databases. WWW: https://github.com/rgeo/rgeo
Notes
Notes: svn path=/head/; revision=466737
Diffstat (limited to 'science/rubygem-rgeo')
-rw-r--r--science/rubygem-rgeo/Makefile20
-rw-r--r--science/rubygem-rgeo/distinfo3
-rw-r--r--science/rubygem-rgeo/pkg-descr21
3 files changed, 44 insertions, 0 deletions
diff --git a/science/rubygem-rgeo/Makefile b/science/rubygem-rgeo/Makefile
new file mode 100644
index 000000000000..6ee2a6333210
--- /dev/null
+++ b/science/rubygem-rgeo/Makefile
@@ -0,0 +1,20 @@
+# Created by: Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= rgeo
+PORTVERSION= 1.0.0
+CATEGORIES= science rubygems
+MASTER_SITES= RG
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Geospatial data library for Ruby (RGeo)
+
+LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE.txt
+
+LIB_DEPENDS= libgeos.so:graphics/geos
+
+USE_RUBY= yes
+USES= gem
+
+.include <bsd.port.mk>
diff --git a/science/rubygem-rgeo/distinfo b/science/rubygem-rgeo/distinfo
new file mode 100644
index 000000000000..7cea2f3745a9
--- /dev/null
+++ b/science/rubygem-rgeo/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1522602101
+SHA256 (rubygem/rgeo-1.0.0.gem) = 8aa0317cc38e1c14ed8e82c3e499f8cb0323f411a08321ad4cb2417235f56694
+SIZE (rubygem/rgeo-1.0.0.gem) = 107008
diff --git a/science/rubygem-rgeo/pkg-descr b/science/rubygem-rgeo/pkg-descr
new file mode 100644
index 000000000000..a51e0e629bc7
--- /dev/null
+++ b/science/rubygem-rgeo/pkg-descr
@@ -0,0 +1,21 @@
+RGeo is a geospatial data library for Ruby.
+
+RGeo is a key component for writing location-aware applications in the Ruby
+programming language. At its core is an implementation of the industry standard
+OGC Simple Features Specification, which provides data representations of
+geometric objects such as points, lines, and polygons, along with a set of
+geometric analysis operations. This makes it ideal for modeling geolocation
+data. It also supports a suite of optional add-on modules that provide various
+geolocation-related services.
+
+Use the core rgeo gem to:
+- Represent spatial and geolocation data objects such as points, lines, and
+ polygons in your Ruby application.
+- Perform standard spatial analysis operations such as finding intersections,
+ creating buffers, and computing lengths and areas.
+- Correctly handle spherical geometry, and compute geographic projections for
+ map display and data analysis.
+- Read and write location data in the WKT and WKB representations used by
+ spatial databases.
+
+WWW: https://github.com/rgeo/rgeo