aboutsummaryrefslogtreecommitdiff
path: root/science/shelxle
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2021-01-14 19:14:12 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2021-01-14 19:14:12 +0000
commitcaad6e42dcb93d1f4bac80c6401e090724b1fc28 (patch)
tree134204b9a7ef670fc4c7e34ed44af0017595ff99 /science/shelxle
parent1c4ba68800193475954f4140d9ab51c2a21a5cdb (diff)
downloadports-caad6e42dcb93d1f4bac80c6401e090724b1fc28.tar.gz
ports-caad6e42dcb93d1f4bac80c6401e090724b1fc28.zip
New port: science/shelxle: Graphical user interface for small-molecule structure refinement
Notes
Notes: svn path=/head/; revision=561586
Diffstat (limited to 'science/shelxle')
-rw-r--r--science/shelxle/Makefile26
-rw-r--r--science/shelxle/distinfo3
-rw-r--r--science/shelxle/files/patch-shelXle.pro22
-rw-r--r--science/shelxle/pkg-descr13
4 files changed, 64 insertions, 0 deletions
diff --git a/science/shelxle/Makefile b/science/shelxle/Makefile
new file mode 100644
index 000000000000..cfd813f0227e
--- /dev/null
+++ b/science/shelxle/Makefile
@@ -0,0 +1,26 @@
+# $FreeBSD$
+
+PORTNAME= shelxle
+DISTVERSION= 1.0.1205
+CATEGORIES= science # chemistry
+MASTER_SITES= SF/${PORTNAME}/code/
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Graphical user interface for small-molecule structure refinement
+
+LICENSE= LGPL21
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+USES= dos2unix gl qmake qt:5 tar:bz2
+DOS2UNIX_FILES= shelXle.pro
+USE_QT= core gui network opengl widgets buildtools_build
+USE_GL= gl
+
+PLIST_FILES= bin/shelxle \
+ share/applications/shelxle.desktop \
+ share/pixmaps/shelxle.png
+
+post-patch:
+ @${FIND} ${WRKSRC} -name "*.cpp" -o -name "*.h" | ${XARGS} ${REINPLACE_CMD} -e 's|NULL|nullptr|g'
+
+.include <bsd.port.mk>
diff --git a/science/shelxle/distinfo b/science/shelxle/distinfo
new file mode 100644
index 000000000000..91349625cf74
--- /dev/null
+++ b/science/shelxle/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1610650046
+SHA256 (shelxle-1.0.1205.tar.bz2) = c6c62e1091e02efaa3a5abfbc32da7adc0d92fda63e82656e4966ebe89202383
+SIZE (shelxle-1.0.1205.tar.bz2) = 3232124
diff --git a/science/shelxle/files/patch-shelXle.pro b/science/shelxle/files/patch-shelXle.pro
new file mode 100644
index 000000000000..0b00bed43bbe
--- /dev/null
+++ b/science/shelxle/files/patch-shelXle.pro
@@ -0,0 +1,22 @@
+--- shelXle.pro.orig 2021-01-14 18:57:12 UTC
++++ shelXle.pro
+@@ -11,15 +11,15 @@ win32 {
+ !mac{
+ unix {
+ TARGET = shelxle
+-target.path = /usr/bin
++target.path = $$PREFIX/bin
+ INSTALLS += target
+-data.path = /usr/share/shelxle
++data.path = $$PREFIX/share/shelxle
+ data.files = help/*
+ INSTALLS += data
+-icon.path = /usr/share/pixmaps
++icon.path = $$PREFIX/share/pixmaps
+ icon.files = shelxle.png
+ INSTALLS += icon
+-desktop.path = /usr/share/applications
++desktop.path = $$PREFIX/share/applications
+ desktop.files = shelxle.desktop
+ INSTALLS += desktop
+ }}
diff --git a/science/shelxle/pkg-descr b/science/shelxle/pkg-descr
new file mode 100644
index 000000000000..e85a94b0dcad
--- /dev/null
+++ b/science/shelxle/pkg-descr
@@ -0,0 +1,13 @@
+ShelXle is a graphical user interface for SHELXL, currently the most widely used
+program for small-molecule structure refinement. It combines an editor with
+syntax highlighting for the SHELXL-associated .ins (input) and .res (output)
+files with an interactive graphical display for visualization of a
+three-dimensional structure including the electron density (Fo) and difference
+density (Fo-Fc) maps. Special features of ShelXle include intuitive atom
+(re-)naming, a strongly coupled editor, structure visualization in various mono
+and stereo modes, and a novel way of displaying disorder extending over special
+positions. ShelXle is completely compatible with all features of SHELXL and is
+written entirely in C++ using the Qt and FFTW libraries. It is available at no
+cost for Windows, Linux and Mac-OS X and as source code.
+
+WWW: https://www.shelxle.org/shelx/eingabe.php