aboutsummaryrefslogtreecommitdiff
path: root/science/siesta
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2018-09-03 17:51:32 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2018-09-03 17:51:32 +0000
commit0e2e493ea3471a9b2ad3cc5b48cffa31ea3bf25f (patch)
tree31bbef0686d97d1aa20ab47ac518c6f5940a344c /science/siesta
parentdd4c7e36aca93d9b1fe5a1f9dc40a041a28e1bd3 (diff)
downloadports-0e2e493ea3471a9b2ad3cc5b48cffa31ea3bf25f.tar.gz
ports-0e2e493ea3471a9b2ad3cc5b48cffa31ea3bf25f.zip
New port: science/siesta: Program to perform efficient electronic structure calculations
Notes
Notes: svn path=/head/; revision=478886
Diffstat (limited to 'science/siesta')
-rw-r--r--science/siesta/Makefile34
-rw-r--r--science/siesta/distinfo3
-rw-r--r--science/siesta/pkg-descr10
3 files changed, 47 insertions, 0 deletions
diff --git a/science/siesta/Makefile b/science/siesta/Makefile
new file mode 100644
index 000000000000..5932d9e57e8d
--- /dev/null
+++ b/science/siesta/Makefile
@@ -0,0 +1,34 @@
+# $FreeBSD$
+
+PORTNAME= siesta
+DISTVERSION= 4.0.2
+CATEGORIES= science
+MASTER_SITES= https://launchpad.net/${PORTNAME}/${DISTVERSION:R}/${DISTVERSION}/+download/
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Program to perform efficient electronic structure calculations
+
+LICENSE= GPLv3
+LICENSE_FILE= ${WRKSRC}/../COPYING
+
+LIB_DEPENDS= libblas.so:math/blas \
+ liblapack.so:math/lapack
+
+USES= fortran gmake localbase:ldflags
+GNU_CONFIGURE= yes
+CONFIGURE_SCRIPT= ../Src/configure
+ALL_TARGET= default
+
+WRKSRC_SUBDIR= Obj
+
+MAKE_JOBS_UNSAFE= yes
+
+PLIST_FILES= bin/${PORTNAME}
+
+pre-configure:
+ @cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${SH} ../Src/obj_setup.sh
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/science/siesta/distinfo b/science/siesta/distinfo
new file mode 100644
index 000000000000..8a520fd4135f
--- /dev/null
+++ b/science/siesta/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1535956967
+SHA256 (siesta-4.0.2.tar.gz) = bafbda19358f0c1dd39bb1253c92ee548791a1c0f648977051d2657216874f7e
+SIZE (siesta-4.0.2.tar.gz) = 9627717
diff --git a/science/siesta/pkg-descr b/science/siesta/pkg-descr
new file mode 100644
index 000000000000..7f1ae0f8577c
--- /dev/null
+++ b/science/siesta/pkg-descr
@@ -0,0 +1,10 @@
+SIESTA is both a method and its computer program implementation, to perform
+efficient electronic structure calculations and ab initio molecular dynamics
+simulations of molecules and solids. SIESTA's efficiency stems from the use of
+strictly localized basis sets and from the implementation of linear-scaling
+algorithms which can be applied to suitable systems. A very important feature
+of the code is that its accuracy and cost can be tuned in a wide range, from
+quick exploratory calculations to highly accurate simulations matching the
+quality of other approaches, such as plane-wave and all-electron methods.
+
+WWW: https://departments.icmab.es/leem/siesta/