aboutsummaryrefslogtreecommitdiff
path: root/science/simgrid
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2019-05-16 16:00:15 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2019-05-16 16:00:15 +0000
commite9a104fd10eddd4a3fa5f5d45663a6bb8cb959b9 (patch)
tree0faceb013c4d6068059994ef05607942212d77b6 /science/simgrid
parent2cc1d3ddbcafcf0acdf9910d0492c35f96596054 (diff)
downloadports-e9a104fd10eddd4a3fa5f5d45663a6bb8cb959b9.tar.gz
ports-e9a104fd10eddd4a3fa5f5d45663a6bb8cb959b9.zip
Notes
Diffstat (limited to 'science/simgrid')
-rw-r--r--science/simgrid/Makefile33
-rw-r--r--science/simgrid/distinfo3
-rw-r--r--science/simgrid/files/patch-tools_cmake_Documentation.cmake8
-rw-r--r--science/simgrid/pkg-descr6
-rw-r--r--science/simgrid/pkg-plist127
5 files changed, 177 insertions, 0 deletions
diff --git a/science/simgrid/Makefile b/science/simgrid/Makefile
new file mode 100644
index 000000000000..e68df643b998
--- /dev/null
+++ b/science/simgrid/Makefile
@@ -0,0 +1,33 @@
+# $FreeBSD$
+
+PORTNAME= SimGrid
+DISTVERSION= 3.22.2.20190515
+CATEGORIES= science
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Simulator of the behavior of large-scale distributed systems
+
+LICENSE= LGPL21
+LICENSE_FILE= ${WRKSRC}/LICENSE-LGPL-2.1
+
+LIB_DEPENDS= libboost_context.so:devel/boost-libs \
+ libcgraph.so:graphics/graphviz \
+ libunwind-ptrace.so:devel/libunwind
+
+USES= cmake:noninja compiler:c++11-lang perl5 python:3.6+ shebangfix
+USE_GITLAB= yes
+GL_SITE= https://framagit.org/
+GL_ACCOUNT= simgrid
+GL_PROJECT= simgrid
+GL_COMMIT= 79b7f7a89ad565a17012ee12c9774c1bd9fa508c
+SHEBANG_FILES= tools/simgrid_convert_TI_traces.py
+USE_LDCONFIG= yes
+INSTALL_TARGET= install/strip
+
+CMAKE_OFF= enable_python
+
+LDFLAGS+= /usr/lib/liblzma.so # workaround for https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=237919
+
+# it'll probably break on gcc-based systems, see https://framagit.org/simgrid/simgrid/issues/12, it'll need CMAKE_OFF=enable_lto and possibly more
+
+.include <bsd.port.mk>
diff --git a/science/simgrid/distinfo b/science/simgrid/distinfo
new file mode 100644
index 000000000000..85269ca9ed62
--- /dev/null
+++ b/science/simgrid/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1558020642
+SHA256 (simgrid-simgrid-79b7f7a89ad565a17012ee12c9774c1bd9fa508c_GL0.tar.gz) = 99927ae31d437aa95414ca1a5fd6455c385e4c614a4a4feeeff333f8ad87bc1f
+SIZE (simgrid-simgrid-79b7f7a89ad565a17012ee12c9774c1bd9fa508c_GL0.tar.gz) = 4027850
diff --git a/science/simgrid/files/patch-tools_cmake_Documentation.cmake b/science/simgrid/files/patch-tools_cmake_Documentation.cmake
new file mode 100644
index 000000000000..2000bb3db4af
--- /dev/null
+++ b/science/simgrid/files/patch-tools_cmake_Documentation.cmake
@@ -0,0 +1,8 @@
+--- tools/cmake/Documentation.cmake.orig 2019-05-16 09:00:44 UTC
++++ tools/cmake/Documentation.cmake
+@@ -137,4 +137,4 @@ install(FILES
+ ${CMAKE_HOME_DIRECTORY}/docs/manpages/smpif90.1
+ ${CMAKE_HOME_DIRECTORY}/docs/manpages/smpiff.1
+ ${CMAKE_HOME_DIRECTORY}/docs/manpages/smpirun.1
+- DESTINATION $ENV{DESTDIR}${CMAKE_INSTALL_PREFIX}/share/man/man1)
++ DESTINATION $ENV{DESTDIR}${CMAKE_INSTALL_PREFIX}/man/man1)
diff --git a/science/simgrid/pkg-descr b/science/simgrid/pkg-descr
new file mode 100644
index 000000000000..94aba29c3501
--- /dev/null
+++ b/science/simgrid/pkg-descr
@@ -0,0 +1,6 @@
+SimGrid is a scientific instrument to study the behavior of large-scale
+distributed systems such as Grids, Clouds, HPC or P2P systems. It can be used to
+evaluate heuristics, prototype applications or even assess legacy MPI
+applications. All this as a free software.
+
+WWW: https://simgrid.org/
diff --git a/science/simgrid/pkg-plist b/science/simgrid/pkg-plist
new file mode 100644
index 000000000000..03fda3c1794e
--- /dev/null
+++ b/science/simgrid/pkg-plist
@@ -0,0 +1,127 @@
+bin/graphicator
+bin/simgrid-colorizer
+bin/simgrid_convert_TI_traces
+bin/simgrid_update_xml
+bin/smpicc
+bin/smpicxx
+bin/smpirun
+bin/tesh
+include/simgrid/Exception.hpp
+include/simgrid/actor.h
+include/simgrid/barrier.h
+include/simgrid/chrono.hpp
+include/simgrid/config.h
+include/simgrid/engine.h
+include/simgrid/forward.h
+include/simgrid/host.h
+include/simgrid/instr.h
+include/simgrid/kernel/future.hpp
+include/simgrid/kernel/resource/Action.hpp
+include/simgrid/kernel/resource/Model.hpp
+include/simgrid/kernel/resource/Resource.hpp
+include/simgrid/kernel/routing/ClusterZone.hpp
+include/simgrid/kernel/routing/DijkstraZone.hpp
+include/simgrid/kernel/routing/DragonflyZone.hpp
+include/simgrid/kernel/routing/EmptyZone.hpp
+include/simgrid/kernel/routing/FatTreeZone.hpp
+include/simgrid/kernel/routing/FloydZone.hpp
+include/simgrid/kernel/routing/FullZone.hpp
+include/simgrid/kernel/routing/NetPoint.hpp
+include/simgrid/kernel/routing/NetZoneImpl.hpp
+include/simgrid/kernel/routing/RoutedZone.hpp
+include/simgrid/kernel/routing/TorusZone.hpp
+include/simgrid/kernel/routing/VivaldiZone.hpp
+include/simgrid/link.h
+include/simgrid/mailbox.h
+include/simgrid/modelchecker.h
+include/simgrid/msg.h
+include/simgrid/plugins/dvfs.h
+include/simgrid/plugins/energy.h
+include/simgrid/plugins/file_system.h
+include/simgrid/plugins/live_migration.h
+include/simgrid/plugins/load.h
+include/simgrid/plugins/load_balancer.h
+include/simgrid/s4u.hpp
+include/simgrid/s4u/Activity.hpp
+include/simgrid/s4u/Actor.hpp
+include/simgrid/s4u/Barrier.hpp
+include/simgrid/s4u/Comm.hpp
+include/simgrid/s4u/ConditionVariable.hpp
+include/simgrid/s4u/Engine.hpp
+include/simgrid/s4u/Exec.hpp
+include/simgrid/s4u/Host.hpp
+include/simgrid/s4u/Io.hpp
+include/simgrid/s4u/Link.hpp
+include/simgrid/s4u/Mailbox.hpp
+include/simgrid/s4u/Mutex.hpp
+include/simgrid/s4u/NetZone.hpp
+include/simgrid/s4u/Semaphore.hpp
+include/simgrid/s4u/Storage.hpp
+include/simgrid/s4u/VirtualMachine.hpp
+include/simgrid/semaphore.h
+include/simgrid/simdag.h
+include/simgrid/simix.h
+include/simgrid/simix.hpp
+include/simgrid/simix/blocking_simcall.hpp
+include/simgrid/smpi/replay.hpp
+include/simgrid/storage.h
+include/simgrid/vm.h
+include/simgrid/zone.h
+include/simgrid_config.h
+include/smpi/forward.hpp
+include/smpi/mpi.h
+include/smpi/mpif.h
+include/smpi/sampi.h
+include/smpi/smpi.h
+include/smpi/smpi_extended_traces.h
+include/smpi/smpi_extended_traces_fortran.h
+include/smpi/smpi_helpers.h
+include/smpi/smpi_helpers_internal.h
+include/smpi/smpi_main.h
+include/xbt.h
+include/xbt/Extendable.hpp
+include/xbt/RngStream.h
+include/xbt/asserts.h
+include/xbt/automaton.h
+include/xbt/automaton.hpp
+include/xbt/backtrace.hpp
+include/xbt/base.h
+include/xbt/config.h
+include/xbt/config.hpp
+include/xbt/dict.h
+include/xbt/dynar.h
+include/xbt/ex.h
+include/xbt/file.hpp
+include/xbt/function_types.h
+include/xbt/functional.hpp
+include/xbt/future.hpp
+include/xbt/graph.h
+include/xbt/log.h
+include/xbt/log.hpp
+include/xbt/mallocator.h
+include/xbt/misc.h
+include/xbt/module.h
+include/xbt/parmap.h
+include/xbt/range.hpp
+include/xbt/replay.hpp
+include/xbt/signal.hpp
+include/xbt/str.h
+include/xbt/string.hpp
+include/xbt/synchro.h
+include/xbt/sysdep.h
+include/xbt/system_error.hpp
+include/xbt/utility.hpp
+include/xbt/virtu.h
+include/xbt/xbt_os_time.h
+lib/libsimgrid.so
+lib/libsimgrid.so.3.22.90
+lib/simgrid/smpimain
+lib/simgrid/smpireplaymain
+libdata/pkgconfig/simgrid.pc
+man/man1/simgrid_update_xml.1.gz
+man/man1/smpicc.1.gz
+man/man1/smpicxx.1.gz
+man/man1/smpif90.1.gz
+man/man1/smpiff.1.gz
+man/man1/smpirun.1.gz
+man/man1/tesh.1.gz