aboutsummaryrefslogtreecommitdiff
path: root/science/simple-dftd3
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2022-01-18 02:33:39 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2022-01-18 02:42:03 +0000
commit8c3413a9f78f04d026de2a4901930fd4e891b311 (patch)
treefb002f59b122d557ce17c264cf68f0fd1429826a /science/simple-dftd3
parentbf689f19eeddbae1c57361a269aa336aea4551b9 (diff)
Diffstat (limited to 'science/simple-dftd3')
-rw-r--r--science/simple-dftd3/Makefile25
-rw-r--r--science/simple-dftd3/distinfo3
-rw-r--r--science/simple-dftd3/pkg-descr6
-rw-r--r--science/simple-dftd3/pkg-plist38
4 files changed, 72 insertions, 0 deletions
diff --git a/science/simple-dftd3/Makefile b/science/simple-dftd3/Makefile
new file mode 100644
index 000000000000..68ec3d62b538
--- /dev/null
+++ b/science/simple-dftd3/Makefile
@@ -0,0 +1,25 @@
+PORTNAME= simple-dftd3
+DISTVERSIONPREFIX= v
+DISTVERSION= 0.5.0
+CATEGORIES= science # chemistry
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Reimplementation of the DFT-D3 program
+
+LICENSE= GPLv3
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+BUILD_DEPENDS= mstore>0:science/mstore # see https://github.com/awvwgk/simple-dftd3/issues/11
+LIB_DEPENDS= libmctc-lib.so:science/mctc-lib \
+ libopenblas.so:math/openblas \
+ libtoml-f.so:textproc/toml-f
+
+USES= cmake:testing fortran
+USE_LDCONFIG= yes
+
+USE_GITHUB= yes
+GH_ACCOUNT= awvwgk
+
+CMAKE_ON= BUILD_SHARED_LIBS
+
+.include <bsd.port.mk>
diff --git a/science/simple-dftd3/distinfo b/science/simple-dftd3/distinfo
new file mode 100644
index 000000000000..88504521e74d
--- /dev/null
+++ b/science/simple-dftd3/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1642472686
+SHA256 (awvwgk-simple-dftd3-v0.5.0_GH0.tar.gz) = 47b2614c911085690075dda5af70391c93d9a43fe067eae15bb6db72eac33aab
+SIZE (awvwgk-simple-dftd3-v0.5.0_GH0.tar.gz) = 433993
diff --git a/science/simple-dftd3/pkg-descr b/science/simple-dftd3/pkg-descr
new file mode 100644
index 000000000000..c875293996de
--- /dev/null
+++ b/science/simple-dftd3/pkg-descr
@@ -0,0 +1,6 @@
+A simple drop-in replacement for dftd3.
+
+This program provides a small and easy to use implementation of the
+DFT-D3 dispersion correction.
+
+WWW: https://github.com/awvwgk/simple-dftd3
diff --git a/science/simple-dftd3/pkg-plist b/science/simple-dftd3/pkg-plist
new file mode 100644
index 000000000000..234042c70b92
--- /dev/null
+++ b/science/simple-dftd3/pkg-plist
@@ -0,0 +1,38 @@
+bin/s-dftd3
+include/dftd3.h
+include/s-dftd3.h
+include/s-dftd3/GNU-10.3.0/dftd3.mod
+include/s-dftd3/GNU-10.3.0/dftd3_api.mod
+include/s-dftd3/GNU-10.3.0/dftd3_blas.mod
+include/s-dftd3/GNU-10.3.0/dftd3_cutoff.mod
+include/s-dftd3/GNU-10.3.0/dftd3_damping.mod
+include/s-dftd3/GNU-10.3.0/dftd3_damping_atm.mod
+include/s-dftd3/GNU-10.3.0/dftd3_damping_mzero.mod
+include/s-dftd3/GNU-10.3.0/dftd3_damping_optimizedpower.mod
+include/s-dftd3/GNU-10.3.0/dftd3_damping_rational.mod
+include/s-dftd3/GNU-10.3.0/dftd3_damping_zero.mod
+include/s-dftd3/GNU-10.3.0/dftd3_data.mod
+include/s-dftd3/GNU-10.3.0/dftd3_data_covrad.mod
+include/s-dftd3/GNU-10.3.0/dftd3_data_r4r2.mod
+include/s-dftd3/GNU-10.3.0/dftd3_data_vdwrad.mod
+include/s-dftd3/GNU-10.3.0/dftd3_disp.mod
+include/s-dftd3/GNU-10.3.0/dftd3_model.mod
+include/s-dftd3/GNU-10.3.0/dftd3_ncoord.mod
+include/s-dftd3/GNU-10.3.0/dftd3_output.mod
+include/s-dftd3/GNU-10.3.0/dftd3_param.mod
+include/s-dftd3/GNU-10.3.0/dftd3_reference.mod
+include/s-dftd3/GNU-10.3.0/dftd3_utils.mod
+include/s-dftd3/GNU-10.3.0/dftd3_version.mod
+lib/cmake/s-dftd3/Findcustom-blas.cmake
+lib/cmake/s-dftd3/Findmctc-lib.cmake
+lib/cmake/s-dftd3/Findmstore.cmake
+lib/cmake/s-dftd3/Findtoml-f.cmake
+lib/cmake/s-dftd3/s-dftd3-config-version.cmake
+lib/cmake/s-dftd3/s-dftd3-config.cmake
+lib/cmake/s-dftd3/s-dftd3-targets-%%CMAKE_BUILD_TYPE%%.cmake
+lib/cmake/s-dftd3/s-dftd3-targets.cmake
+lib/cmake/s-dftd3/s-dftd3-utils.cmake
+lib/libs-dftd3.so
+lib/libs-dftd3.so.0
+lib/libs-dftd3.so.0.5.0
+libdata/pkgconfig/s-dftd3.pc