aboutsummaryrefslogtreecommitdiff
path: root/science/simsmith
diff options
context:
space:
mode:
authorStephen Hurd <shurd@FreeBSD.org>2014-07-03 21:02:10 +0000
committerStephen Hurd <shurd@FreeBSD.org>2014-07-03 21:02:10 +0000
commitf1189cb220d546bcae63dc32808a1cb21e776f6d (patch)
tree6647c79538acb98c705a240b7c7034311da6f5ff /science/simsmith
parent6254c184d8139e1f88066a25e900804fda28c69d (diff)
downloadports-f1189cb220d546bcae63dc32808a1cb21e776f6d.tar.gz
ports-f1189cb220d546bcae63dc32808a1cb21e776f6d.zip
Java based Smith chart program. Performs single-frequency and sweep charting
with both Smitch charts and SWR/PWR curves. Does drag-and-drop schematic entry with direct entry of component values as well as "drag tuning". Can import load parameters directly from the following: - EZNEC (and EZNEC GAM files) - miniVNA and miniVNApro - AIM4170 - CocoaNEC - Rig Expert ".aaplot" files - Touchstone S1P ".s1p" files (shunt and series) Reviewed by: db, skreuzer Approved by: db, skreuzer (mentors) Differential Revision: https://phabric.freebsd.org/D311
Notes
Notes: svn path=/head/; revision=360457
Diffstat (limited to 'science/simsmith')
-rw-r--r--science/simsmith/Makefile31
-rw-r--r--science/simsmith/distinfo2
-rw-r--r--science/simsmith/files/simsmith.in5
-rw-r--r--science/simsmith/pkg-descr13
4 files changed, 51 insertions, 0 deletions
diff --git a/science/simsmith/Makefile b/science/simsmith/Makefile
new file mode 100644
index 000000000000..f460a591a838
--- /dev/null
+++ b/science/simsmith/Makefile
@@ -0,0 +1,31 @@
+# Created by: shurd@FreeBSD.org
+# $FreeBSD$
+
+PORTNAME= simsmith
+PORTVERSION= 9.9
+CATEGORIES= science hamradio
+MASTER_SITES= http://ae6ty.com/Smith_Charts_files/ \
+ ${MASTER_SITE_LOCAL}
+MASTER_SITE_SUBDIR= shurd
+DISTNAME= SimSmith9p9
+EXTRACT_SUFX= .jar
+EXTRACT_ONLY=
+
+MAINTAINER= hamradio@FreeBSD.org
+COMMENT= A Java-based Smith Chart program
+
+USE_JAVA= yes
+JAVA_VERSION= 1.6+
+JAVA_RUN= yes
+
+PLIST_FILES= %%JAVAJARDIR%%/${DISTNAME}${EXTRACT_SUFX} \
+ bin/${PORTNAME}
+SUB_FILES= simsmith
+SUB_LIST+= DISTNAME=${DISTNAME}
+NO_BUILD= yes
+
+do-install:
+ @${INSTALL_DATA} ${DISTDIR}/${DISTNAME}${EXTRACT_SUFX} ${STAGEDIR}${JAVAJARDIR}
+ @${INSTALL_SCRIPT} ${WRKDIR}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/science/simsmith/distinfo b/science/simsmith/distinfo
new file mode 100644
index 000000000000..d35fe140ff42
--- /dev/null
+++ b/science/simsmith/distinfo
@@ -0,0 +1,2 @@
+SHA256 (SimSmith9p9.jar) = 2cedb3e5467fd2a0c0609c347a2fdfe4021532c94d23599dd11f85fb8a327605
+SIZE (SimSmith9p9.jar) = 3646770
diff --git a/science/simsmith/files/simsmith.in b/science/simsmith/files/simsmith.in
new file mode 100644
index 000000000000..e5f359395be4
--- /dev/null
+++ b/science/simsmith/files/simsmith.in
@@ -0,0 +1,5 @@
+#!/bin/sh
+#
+# $FreeBSD$
+
+JAVA_VERSION="%%JAVA_VERSION%%" "%%LOCALBASE%%/bin/java" -jar "%%JAVAJARDIR%%/%%DISTNAME%%.jar" "$@"
diff --git a/science/simsmith/pkg-descr b/science/simsmith/pkg-descr
new file mode 100644
index 000000000000..4db01b835f55
--- /dev/null
+++ b/science/simsmith/pkg-descr
@@ -0,0 +1,13 @@
+Java based Smith chart program. Performs single-frequency and sweep charting
+with both Smitch charts and SWR/PWR curves. Does drag-and-drop schematic entry
+with direct entry of component values as well as "drag tuning". Can import
+load parameters directly from the following:
+
+- EZNEC (and EZNEC GAM files)
+- miniVNA and miniVNApro
+- AIM4170
+- CocoaNEC
+- Rig Expert ".aaplot" files
+- Touchstone S1P ".s1p" files (shunt and series)
+
+WWW: http://ae6ty.com/Smith_Charts.html