aboutsummaryrefslogtreecommitdiff
path: root/science/udunits
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2021-01-03 20:05:21 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2021-01-03 20:05:21 +0000
commit424da78664140df43587069a30a22414156f4e6f (patch)
treec8526f10172affef375b3598e520feaccdab80cc /science/udunits
parent23f93d6d1f6e2a8165034b5301ff2ddafd6c8039 (diff)
downloadports-424da78664140df43587069a30a22414156f4e6f.tar.gz
ports-424da78664140df43587069a30a22414156f4e6f.zip
Update to 2.2.28
Notes
Notes: svn path=/head/; revision=560099
Diffstat (limited to 'science/udunits')
-rw-r--r--science/udunits/Makefile9
-rw-r--r--science/udunits/distinfo6
-rw-r--r--science/udunits/files/patch-lib-xml.c20
3 files changed, 28 insertions, 7 deletions
diff --git a/science/udunits/Makefile b/science/udunits/Makefile
index 4f108c3a3054..50af970d3a5f 100644
--- a/science/udunits/Makefile
+++ b/science/udunits/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= udunits
-PORTVERSION= 2.2.26
-PORTREVISION= 2
+PORTVERSION= 2.2.28
CATEGORIES= science math
MASTER_SITES= ftp://ftp.unidata.ucar.edu/pub/udunits/ \
LOCAL/sunpoet
@@ -18,17 +17,19 @@ LICENSE_PERMS= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
LIB_DEPENDS= libexpat.so:textproc/expat2
-OPTIONS_DEFINE= DOCS
+USES= libtool localbase
+CFLAGS+= -D__BSD_VISIBLE
CONFIGURE_ENV= ac_cv_header_CUnit_CUnit_h=no
GNU_CONFIGURE= yes
INSTALL_TARGET= install-strip
TEST_TARGET= check
USE_LDCONFIG= yes
-USES= libtool localbase
INFO= udunits2 udunits2lib udunits2prog
+OPTIONS_DEFINE= DOCS
+
post-patch:
@${REINPLACE_CMD} -e '/install-data-hook$$/d' ${WRKSRC}/lib/Makefile.in
diff --git a/science/udunits/distinfo b/science/udunits/distinfo
index de3717266f9b..53c07f01144b 100644
--- a/science/udunits/distinfo
+++ b/science/udunits/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1514030046
-SHA256 (udunits-2.2.26.tar.gz) = 368f4869c9c7d50d2920fa8c58654124e9ed0d8d2a8c714a9d7fdadc08c7356d
-SIZE (udunits-2.2.26.tar.gz) = 1227596
+TIMESTAMP = 1609598847
+SHA256 (udunits-2.2.28.tar.gz) = 590baec83161a3fd62c00efa66f6113cec8a7c461e3f61a5182167e0cc5d579e
+SIZE (udunits-2.2.28.tar.gz) = 1224503
diff --git a/science/udunits/files/patch-lib-xml.c b/science/udunits/files/patch-lib-xml.c
new file mode 100644
index 000000000000..01ca8725676e
--- /dev/null
+++ b/science/udunits/files/patch-lib-xml.c
@@ -0,0 +1,20 @@
+--- lib/xml.c.orig 2020-12-07 18:37:03 UTC
++++ lib/xml.c
+@@ -38,7 +38,7 @@
+ #endif
+ #include <sys/stat.h>
+ #include <sys/types.h>
+-#if defined(__linux__)
++#if defined(__linux__) || defined(__FreeBSD__)
+ #include <dlfcn.h>
+ #elif defined(__APPLE__)
+ #define _DARWIN_C_SOURCE
+@@ -2137,7 +2137,7 @@ default_udunits2_xml_path()
+ if (absXmlPathname[0] == 0) {
+ const char* prefix = NULL; // Installation directory
+
+-# if defined(__APPLE__) || defined(__linux__)
++# if defined(__APPLE__) || defined(__linux__) || defined(__FreeBSD__)
+ Dl_info info;
+ const char sep = '/'; // Pathname component separator
+ char buf[PATH_MAX];