aboutsummaryrefslogtreecommitdiff
path: root/science/v_sim/Makefile
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2008-06-03 05:52:40 +0000
committerThierry Thomas <thierry@FreeBSD.org>2008-06-03 05:52:40 +0000
commitfd2a763ea9baf0dd93dfd8abf00715c658b5e680 (patch)
tree3cb2c4b355e80c3a28da93298c17123dd1b9ebcc /science/v_sim/Makefile
parent2b3163be5b2876d66873890daf7941c2899e7a22 (diff)
downloadports-fd2a763ea9baf0dd93dfd8abf00715c658b5e680.tar.gz
ports-fd2a763ea9baf0dd93dfd8abf00715c658b5e680.zip
Notes
Diffstat (limited to 'science/v_sim/Makefile')
-rw-r--r--science/v_sim/Makefile14
1 files changed, 7 insertions, 7 deletions
diff --git a/science/v_sim/Makefile b/science/v_sim/Makefile
index 8927ba80ee10..8835319ff2f6 100644
--- a/science/v_sim/Makefile
+++ b/science/v_sim/Makefile
@@ -5,19 +5,21 @@
# $FreeBSD$
PORTNAME= v_sim
-PORTVERSION= 3.3.3
+PORTVERSION= 3.4.0
CATEGORIES= science
MASTER_SITES= http://www-drfmc.cea.fr/sp2m/L_Sim/V_Sim/download/
MAINTAINER= thierry@FreeBSD.org
COMMENT= Visualization of atomic structures
+LIB_DEPENDS= cairo:${PORTSDIR}/graphics/cairo
+
USE_BZIP2= yes
USE_GNOME= gtk20
USE_GL= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --disable-gtk-doc
+CONFIGURE_ARGS= --disable-gtk-doc --with-html-dir=${PREFIX}/share/doc
CONFIGURE_ENV= CPPFLAGS="${CFLAGS} -I${LOCALBASE}/include" \
LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib"
@@ -34,10 +36,10 @@ PLIST_SUB+= NLS=""
.if !defined(WITHOUT_CDF)
LIB_DEPENDS+= netcdf.4:${PORTSDIR}/science/netcdf
-CONFIGURE_ARGS+=--with-nanoquanta --with-nanoquanta-path=${LOCALBASE}
+CONFIGURE_ARGS+=--with-netcdf=${LOCALBASE}
PLIST_SUB+= CDF=""
.else
-CONFIGURE_ARGS+=--without-nanoquanta
+CONFIGURE_ARGS+=--without-netcdf
PLIST_SUB+= CDF="@comment "
.endif
@@ -53,10 +55,8 @@ PLIST_SUB+= BABEL="@comment "
pre-configure:
${REINPLACE_CMD} -e 's|$$datadir/doc/$$PACKAGE/examples|${EXAMPLESDIR}|' \
-e 's|CFLAGS="-O2"|#CFLAGS="-O2"|;s|Werror ansi pedantic-errors||' \
+ -e 's|$${docdir}/examples|${EXAMPLESDIR}|' \
${WRKSRC}/${CONFIGURE_SCRIPT}
- ${REINPLACE_CMD} -e 's|-Werror||' ${WRKSRC}/src/Makefile.in
- ${REINPLACE_CMD} -e 's|-pedantic-errors||' \
- ${WRKSRC}/src/extraGtkFunctions/Makefile.in
.if defined(WITHOUT_NLS)
${REINPLACE_CMD} -e 's| po ||' \
${WRKSRC}/Makefile.in