aboutsummaryrefslogtreecommitdiff
path: root/science
diff options
context:
space:
mode:
authorMarcelo Araujo <araujo@FreeBSD.org>2007-07-15 16:12:19 +0000
committerMarcelo Araujo <araujo@FreeBSD.org>2007-07-15 16:12:19 +0000
commit025104e02eedef0557a64a507d86a6f907e2c06f (patch)
treec137783a237a315748c4aedad07a34f15882360f /science
parent418670d7621cda0caa80ecfaeaaaeeeaf7227e24 (diff)
downloadports-025104e02eedef0557a64a507d86a6f907e2c06f.tar.gz
ports-025104e02eedef0557a64a507d86a6f907e2c06f.zip
Notes
Diffstat (limited to 'science')
-rw-r--r--science/elmer-eio/Makefile5
-rw-r--r--science/elmer-hutiter/Makefile7
-rw-r--r--science/elmer-meshgen2d/Makefile5
-rw-r--r--science/elmerfront/Makefile5
-rw-r--r--science/elmerpost/Makefile5
5 files changed, 7 insertions, 20 deletions
diff --git a/science/elmer-eio/Makefile b/science/elmer-eio/Makefile
index 6de1ee1b5fc9..20f6e68be630 100644
--- a/science/elmer-eio/Makefile
+++ b/science/elmer-eio/Makefile
@@ -14,10 +14,7 @@ PKGNAMEPREFIX= elmer-
MAINTAINER= araujo@FreeBSD.org
COMMENT= ELMER FEM Package Data base Interface
-BUILD_DEPENDS+= gfortran42:${PORTSDIR}/lang/gcc42
-
-FC= gfortran42
-F77= gfortran42
+USE_FORTRAN= yes
CONFIGURE_ENV+= FC=${FC} F77=${FC} FCFLAGS=${FCFLAGS}
GNU_CONFIGURE= yes
diff --git a/science/elmer-hutiter/Makefile b/science/elmer-hutiter/Makefile
index cf76cc784525..ddab5a26d6e3 100644
--- a/science/elmer-hutiter/Makefile
+++ b/science/elmer-hutiter/Makefile
@@ -16,6 +16,8 @@ COMMENT= HUTIter library for use in the ELMER FEM package
LIB_DEPENDS= arpack.1:${PORTSDIR}/math/arpack
+USE_FORTRAN= yes
+
.include <bsd.port.pre.mk>
.if exists(${LOCALBASE}/lib/libatlas_r.so) && !defined(WITH_BLAS)
@@ -32,11 +34,6 @@ BLAS= -lblas
LAPACK= -llapack
.endif
-WANT_FORTRAN= yes #dummy but future use
-BUILD_DEPENDS+= gfortran42:${PORTSDIR}/lang/gcc42
-FC= gfortran42
-F77= gfortran42
-
post-patch:
@${REINPLACE_CMD} -e 's|%%CC%%|${CC}|' -e 's|%%FC%%|${FC}|' ${WRKSRC}/configure.in
diff --git a/science/elmer-meshgen2d/Makefile b/science/elmer-meshgen2d/Makefile
index cb8e9abf27f8..be3f0eb6c38d 100644
--- a/science/elmer-meshgen2d/Makefile
+++ b/science/elmer-meshgen2d/Makefile
@@ -15,10 +15,7 @@ PKGNAMEPREFIX= elmer-
MAINTAINER= araujo@FreeBSD.org
COMMENT= A Mesh Generation Utility for use with the ELMER FEM package
-WANT_FORTRAN=yes #dummy but future use
-BUILD_DEPENDS+= gfortran42:${PORTSDIR}/lang/gcc42
-FC= gfortran42
-F77= gfortran42
+USE_FORTRAN= yes
GNU_CONFIGURE= yes
ALL_TARGET=
diff --git a/science/elmerfront/Makefile b/science/elmerfront/Makefile
index 4fffeac7d978..79b0c2f0f4cc 100644
--- a/science/elmerfront/Makefile
+++ b/science/elmerfront/Makefile
@@ -28,10 +28,7 @@ RUN_DEPENDS= wish8.4:${PORTSDIR}/x11-toolkits/tk84 \
# on older systems (Irix)
CXXFLAGS+= -Wno-deprecated
-WANT_FORTRAN= yes #dummy but future use
-BUILD_DEPENDS+= gfortran42:${PORTSDIR}/lang/gcc42
-FC= gfortran42
-F77= gfortran42
+USE_FORTRAN= yes
USE_GCC= 3.4
USE_GL= yes
GNU_CONFIGURE= yes
diff --git a/science/elmerpost/Makefile b/science/elmerpost/Makefile
index 17841924938b..04186aa6a630 100644
--- a/science/elmerpost/Makefile
+++ b/science/elmerpost/Makefile
@@ -27,9 +27,8 @@ GNU_CONFIGURE= yes
USE_GMAKE= yes
ALL_TARGET=
-WANT_FORTRAN= yes
-BUILD_DEPENDS+= gfortran42:${PORTSDIR}/lang/gcc42
-CONFIGURE_ENV+= FC=gfortran42 F77=gfortran42 FCFLAGS=${FCFLAGS}
+USE_FORTRAN= yes
+CONFIGURE_ENV+= FC=${FC} F77=${FC} FCFLAGS=${FCFLAGS}
PLIST_SUB= ARCH=${MACHINE_ARCH}