aboutsummaryrefslogtreecommitdiff
path: root/science
diff options
context:
space:
mode:
authorVasil Dimov <vd@FreeBSD.org>2006-02-08 11:55:08 +0000
committerVasil Dimov <vd@FreeBSD.org>2006-02-08 11:55:08 +0000
commit26a86dd2371f8b229e73488d488ba6b49d8b617b (patch)
treea17a1be31f80a0d4f1f456ca01a973e950247009 /science
parent92d3c7ecdd4426dab6f77fc89dcfb7d289b39540 (diff)
downloadports-26a86dd2371f8b229e73488d488ba6b49d8b617b.tar.gz
ports-26a86dd2371f8b229e73488d488ba6b49d8b617b.zip
Notes
Diffstat (limited to 'science')
-rw-r--r--science/Makefile1
-rw-r--r--science/glens/Makefile49
-rw-r--r--science/glens/distinfo3
-rw-r--r--science/glens/files/patch-mat.cpp10
-rw-r--r--science/glens/files/patch-ui.cpp30
-rw-r--r--science/glens/pkg-descr6
-rw-r--r--science/glens/pkg-plist16
7 files changed, 0 insertions, 115 deletions
diff --git a/science/Makefile b/science/Makefile
index 8d5e172aecc7..d89d0d6e915b 100644
--- a/science/Makefile
+++ b/science/Makefile
@@ -27,7 +27,6 @@
SUBDIR += gerris
SUBDIR += getdp
SUBDIR += ghemical
- SUBDIR += glens
SUBDIR += gnudatalanguage
SUBDIR += gramps
SUBDIR += gromacs
diff --git a/science/glens/Makefile b/science/glens/Makefile
deleted file mode 100644
index 23a4cd7163f7..000000000000
--- a/science/glens/Makefile
+++ /dev/null
@@ -1,49 +0,0 @@
-# ex:ts=8
-# Ports collection Makefile for: glens
-# Date created: Aug 8, 2002
-# Whom: ijliao
-#
-# $FreeBSD$
-#
-
-PORTNAME= glens
-PORTVERSION= 0.3
-PORTREVISION= 2
-CATEGORIES= science
-MASTER_SITES= # no longer available
-
-MAINTAINER= ports@FreeBSD.org
-COMMENT= OpenGL gravitational lens simulator
-
-DEPRECATED= no longer available from mastersite
-EXPIRATION_DATE= 2006-01-25
-
-BUILD_DEPENDS= ${X11BASE}/lib/libglui.a:${PORTSDIR}/devel/glui
-LIB_DEPENDS= glut.4:${PORTSDIR}/graphics/libglut
-
-USE_REINPLACE= yes
-GNU_CONFIGURE= yes
-CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
-CONFIGURE_ARGS= --with-glui=${X11BASE}
-
-CPPFLAGS= -I${LOCALBASE}/include -I${X11BASE}/include ${PTHREAD_CFLAGS}
-LDFLAGS= -L${LOCALBASE}/lib -L${X11BASE}/lib ${PTHREAD_LIBS}
-
-.include <bsd.port.pre.mk>
-
-.if ${ARCH} == "alpha"
-BROKEN= "Does not compile on alpha"
-.endif
-
-post-patch:
- @${REINPLACE_CMD} -e \
- 's|-O6||g ; \
- s|-malign-double||g' ${WRKSRC}/configure
-
-post-install:
-.if !defined(NOPORTDOCS)
- @${MKDIR} ${EXAMPLESDIR}/cfg
- ${INSTALL_DATA} ${WRKSRC}/cfg/*.cgf ${EXAMPLESDIR}/cfg
-.endif
-
-.include <bsd.port.post.mk>
diff --git a/science/glens/distinfo b/science/glens/distinfo
deleted file mode 100644
index 4b34b88c810d..000000000000
--- a/science/glens/distinfo
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 (glens-0.3.tar.gz) = 4edfcca793d8671a6774cd4fb9295a44
-SHA256 (glens-0.3.tar.gz) = 833e66297107697f6970993fc6f155e8ffcb60643e605973d25aa00184ccd3c2
-SIZE (glens-0.3.tar.gz) = 373037
diff --git a/science/glens/files/patch-mat.cpp b/science/glens/files/patch-mat.cpp
deleted file mode 100644
index 55d691669bc3..000000000000
--- a/science/glens/files/patch-mat.cpp
+++ /dev/null
@@ -1,10 +0,0 @@
---- src/mat.cpp.orig Thu Aug 8 16:29:42 2002
-+++ src/mat.cpp Thu Aug 8 16:29:55 2002
-@@ -12,6 +12,7 @@
-
- #include <math.h>
- #include <stdio.h>
-+#include <stdlib.h>
- #include "mat.h"
-
- void inverse(view *in, view *out)
diff --git a/science/glens/files/patch-ui.cpp b/science/glens/files/patch-ui.cpp
deleted file mode 100644
index 5faee6ea96aa..000000000000
--- a/science/glens/files/patch-ui.cpp
+++ /dev/null
@@ -1,30 +0,0 @@
---- src/ui.cpp.orig Tue Aug 17 15:50:17 2004
-+++ src/ui.cpp Tue Aug 17 15:56:34 2004
-@@ -320,7 +320,7 @@
-
- GLUI_RadioGroup *group = win_control->add_radiogroup_to_panel(panel, &d,1,ctrl_callback);
-
-- radio = new (GLUI_RadioButton*)[ndefl];
-+ radio = new GLUI_RadioButton*[ndefl];
-
- for(i=0;i<ndefl;i++)
- {
-@@ -406,12 +406,12 @@
-
- int i;
-
-- st = new (GLUI_StaticText*)[n];
-- cb = new (GLUI_Checkbox*)[n];
-- ex = new (GLUI_EditText*)[n];
-- ey = new (GLUI_EditText*)[n];
-- ez = new (GLUI_EditText*)[n];
-- em = new (GLUI_EditText*)[n];
-+ st = new GLUI_StaticText*[n];
-+ cb = new GLUI_Checkbox*[n];
-+ ex = new GLUI_EditText*[n];
-+ ey = new GLUI_EditText*[n];
-+ ez = new GLUI_EditText*[n];
-+ em = new GLUI_EditText*[n];
-
- char text[10];
-
diff --git a/science/glens/pkg-descr b/science/glens/pkg-descr
deleted file mode 100644
index 4a68375af9db..000000000000
--- a/science/glens/pkg-descr
+++ /dev/null
@@ -1,6 +0,0 @@
-Glens simulates a gravitational lens composed of any number of punctual
-deflectors. Light comes from a punctual light source at an infinite distance,
-the direction of which can be specified. It is then deflected by a
-distribution of punctual deflectors (such as a black hole) into a small
-region of space. The rays can be seen, and directions and parameters
-specified to see multiple images, or the famous "Einstein ring".
diff --git a/science/glens/pkg-plist b/science/glens/pkg-plist
deleted file mode 100644
index d8fa06533e73..000000000000
--- a/science/glens/pkg-plist
+++ /dev/null
@@ -1,16 +0,0 @@
-bin/glens
-%%PORTDOCS%%share/examples/glens/cfg/bh.cgf
-%%PORTDOCS%%share/examples/glens/cfg/conf1.cgf
-%%PORTDOCS%%share/examples/glens/cfg/conf2.cgf
-%%PORTDOCS%%share/examples/glens/cfg/conf3.cgf
-%%PORTDOCS%%share/examples/glens/cfg/conf4.cgf
-%%PORTDOCS%%share/examples/glens/cfg/conf5.cgf
-%%PORTDOCS%%share/examples/glens/cfg/conf6.cgf
-%%PORTDOCS%%share/examples/glens/cfg/conf7.cgf
-%%PORTDOCS%%share/examples/glens/cfg/conf9.cgf
-%%PORTDOCS%%share/examples/glens/cfg/confbad.cgf
-%%PORTDOCS%%share/examples/glens/cfg/glens.cgf
-%%PORTDOCS%%share/examples/glens/cfg/simple.cgf
-%%PORTDOCS%%share/examples/glens/cfg/simple2.cgf
-%%PORTDOCS%%@dirrm share/examples/glens/cfg
-%%PORTDOCS%%@dirrm share/examples/glens