aboutsummaryrefslogtreecommitdiff
path: root/science
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2022-06-19 09:55:17 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2022-06-19 10:01:29 +0000
commit2c60c1ad511796f490e60bccefbca0fc845f4317 (patch)
tree43b415e12b8e3279ed2a85a3585995a7dedc3a1d /science
parent30c83a16357160df2b8eaacf28d3b6ad5c965eb9 (diff)
downloadports-2c60c1ad511796f490e60bccefbca0fc845f4317.tar.gz
ports-2c60c1ad511796f490e60bccefbca0fc845f4317.zip
science/py-ase: Add test target
Diffstat (limited to 'science')
-rw-r--r--science/py-ase/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/science/py-ase/Makefile b/science/py-ase/Makefile
index b2fe14bbd783..fac8fbd498a5 100644
--- a/science/py-ase/Makefile
+++ b/science/py-ase/Makefile
@@ -14,10 +14,16 @@ RUN_DEPENDS= ${PYNUMPY} \
${PYTHON_PKGNAMEPREFIX}matplotlib>=3.1.0:math/py-matplotlib@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}scipy>=1.1.0:science/py-scipy@${PY_FLAVOR} \
nwchem:science/nwchem
+TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytest-mock>0:devel/py-pytest-mock@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pytest-xdist>=1.30.0:devel/py-pytest-xdist@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}asap3>0:science/py-asap3@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}Flask>0:www/py-flask@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}netCDF4>0:science/py-netCDF4@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}spglib>0:science/py-spglib@${PY_FLAVOR}
# optional dependencies: x11-toolkits/py-tkinter, www/py-flask (see https://wiki.fysik.dtu.dk/ase/install.html)
USES= python:3.7+
-USE_PYTHON= distutils concurrent autoplist
+USE_PYTHON= distutils concurrent autoplist pytest
NO_ARCH= yes