aboutsummaryrefslogtreecommitdiff
path: root/science
diff options
context:
space:
mode:
authorMaho Nakata <maho@FreeBSD.org>2007-07-14 02:56:36 +0000
committerMaho Nakata <maho@FreeBSD.org>2007-07-14 02:56:36 +0000
commit3034d94e677c00cc00546fe59b90130e23d419e7 (patch)
tree95c766cdd826712bc89c06e598577d27e09b5499 /science
parentbf8612ab0a529962905e293af7c211cb74cbb55b (diff)
downloadports-3034d94e677c00cc00546fe59b90130e23d419e7.tar.gz
ports-3034d94e677c00cc00546fe59b90130e23d419e7.zip
Notes
Diffstat (limited to 'science')
-rw-r--r--science/getdp/Makefile8
-rw-r--r--science/isaac-cfd/Makefile5
-rw-r--r--science/libctl/Makefile5
-rw-r--r--science/mpb/Makefile5
-rw-r--r--science/oases/Makefile6
5 files changed, 6 insertions, 23 deletions
diff --git a/science/getdp/Makefile b/science/getdp/Makefile
index 9d866824874b..64e5d50fadcc 100644
--- a/science/getdp/Makefile
+++ b/science/getdp/Makefile
@@ -19,13 +19,9 @@ COMMENT= A rather general finite element solver using mixed finite elements
LIB_DEPENDS= gsl.10:${PORTSDIR}/math/gsl \
lapack.4:${PORTSDIR}/math/lapack
-WANT_FORTRAN= yes #dummy but future use
-BUILD_DEPENDS+= gfortran42:${PORTSDIR}/lang/gcc42
-FC= gfortran42
-F77= gfortran42
-CONFIGURE_ENV+= FC="${FC}" F77="${F77}" FFLAGS="${FFLAGS}"
-
+USE_FORTRAN= yes
GNU_CONFIGURE= yes
+CONFIGURE_ENV+= FC="${FC}" F77="${F77}" FFLAGS="${FFLAGS}"
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ARGS= --with-gsl-prefix=${LOCALBASE} \
--with-blas-lapack-prefix=${LOCALBASE}
diff --git a/science/isaac-cfd/Makefile b/science/isaac-cfd/Makefile
index 2ab0bba5e332..4ddfe0d6ba08 100644
--- a/science/isaac-cfd/Makefile
+++ b/science/isaac-cfd/Makefile
@@ -28,10 +28,7 @@ NO_WRKSUBDIR= yes
USE_GMAKE= yes
MAKEFILE= makefile
MAKE_FLAGS+= CPPFLAGS=-I.
-WANT_FORTRAN= yes #dummy but future use
-BUILD_DEPENDS+= gfortran42:${PORTSDIR}/lang/gcc42
-FC= gfortran42
-F77= gfortran42
+USE_FORTRAN= yes
.if !defined(WITH_EXAMPLES)
PLIST_SUB= WITH_EXAMPLES="@comment "
diff --git a/science/libctl/Makefile b/science/libctl/Makefile
index 5716c220f99a..1a4456cb6743 100644
--- a/science/libctl/Makefile
+++ b/science/libctl/Makefile
@@ -19,10 +19,7 @@ LIB_DEPENDS= guile.15:${PORTSDIR}/lang/guile
GNU_CONFIGURE= yes
CONFIGURE_ENV+= FC="${FC}" F77="${F77}" FFLAGS="${FFLAGS}"
-WANT_FORTRAN=yes #dummy but future use
-BUILD_DEPENDS+= gfortran42:${PORTSDIR}/lang/gcc42
-FC= gfortran42
-F77= gfortran42
+USE_FORTRAN= yes
MAN1= gen-ctl-io.1
diff --git a/science/mpb/Makefile b/science/mpb/Makefile
index c0682c1b19e0..5d6ba6392503 100644
--- a/science/mpb/Makefile
+++ b/science/mpb/Makefile
@@ -21,10 +21,7 @@ LIB_DEPENDS= fftw.2:${PORTSDIR}/math/fftw \
hdf5.0:${PORTSDIR}/science/hdf5 \
guile.15:${PORTSDIR}/lang/guile
-WANT_FORTRAN= yes #dummy but future use
-BUILD_DEPENDS+= gfortran42:${PORTSDIR}/lang/gcc42
-FC= gfortran42
-F77= gfortran42
+USE_FORTRAN= yes
.include <bsd.port.pre.mk>
GNU_CONFIGURE= yes
diff --git a/science/oases/Makefile b/science/oases/Makefile
index 52996df759c6..a54060f38167 100644
--- a/science/oases/Makefile
+++ b/science/oases/Makefile
@@ -21,11 +21,7 @@ WRKSRC= ${WRKDIR}/Oases_export
USE_XLIB= yes
MAKE_ENV+= OASES_ROOT="${WRKSRC}"
-WANT_FORTRAN= yes #dummy but future use
-BUILD_DEPENDS+= gfortran42:${PORTSDIR}/lang/gcc42
-FC= gfortran42
-F77= gfortran42
-MAKE_ENV+= FC="${FC}" F77="${F77}" FFLAGS="${FFLAGS}"
+USE_FORTRAN= yes
SCRIPT= avbeam bistat cplot mplot mtvplot multmtv oasn oasp oasr \
oass oassp oast plp2mtv