aboutsummaryrefslogtreecommitdiff
path: root/science
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2018-07-18 00:20:27 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2018-07-18 00:20:27 +0000
commit3b61536f7c0e2b5f0031913e10f09182a635b932 (patch)
treef4f8f12824e6f65f8eefe2f1c6ec57651d5cf721 /science
parent94591790a1939f8c538031a50d34462354f497b5 (diff)
downloadports-3b61536f7c0e2b5f0031913e10f09182a635b932.tar.gz
ports-3b61536f7c0e2b5f0031913e10f09182a635b932.zip
Notes
Diffstat (limited to 'science')
-rw-r--r--science/mpqc/Makefile16
-rw-r--r--science/mpqc/files/patch-src_lib_chemistry_qc_cints_Makefile19
-rw-r--r--science/mpqc/files/patch-src_lib_util_misc_Makefile10
-rw-r--r--science/mpqc/files/patch-symmetry__pointgrp.cc10
4 files changed, 40 insertions, 15 deletions
diff --git a/science/mpqc/Makefile b/science/mpqc/Makefile
index 842cca794463..af2c6d3cea28 100644
--- a/science/mpqc/Makefile
+++ b/science/mpqc/Makefile
@@ -3,28 +3,33 @@
PORTNAME= mpqc
PORTVERSION= 2.3.1
-PORTREVISION= 33
+PORTREVISION= 34
CATEGORIES= science parallel
MASTER_SITES= SF
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= yuri@FreeBSD.org
COMMENT= Massively Parallel Quantum Chemistry Program
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/COPYING
+
BROKEN_aarch64= fails to compile: lapack.h:2:10: 'chemistry/qc/mbptr12/f77sym.h' file not found
LIB_DEPENDS= libint.so:science/libint
+RUN_DEPENDS= wish:x11-toolkits/tk-wrapper
+
+CONFLICTS_BUILD= ga # devel/ga: it links to libarmci.so, has HAVE_ARMCI defined, and hits some bug
+USES= fortran gmake libtool localbase perl5 shebangfix tar:bzip2
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-production \
--enable-shared \
--with-cc-optflags="${CFLAGS}" \
--with-cxx-optflags="${CXXFLAGS}" \
--with-sc-datadir=${DATADIR}
-LIBS+= -Wl,--as-needed -lexecinfo -Wl,--no-as-needed
ALL_TARGET= default
INSTALL_TARGET= install install_devel
DESTDIRNAME= installroot
-USES= fortran gmake libtool localbase perl5 shebangfix tar:bzip2
SHEBANG_FILES= src/bin/mpqc/ccarunproc src/bin/mpqc/mpqcrunproc
USE_LDCONFIG= yes
@@ -44,7 +49,7 @@ DOXYGEN_BUILD_DEPENDS= doxygen:devel/doxygen \
dot:graphics/graphviz
ICC_BUILD_DEPENDS= ${LOCALBASE}/intel_cc_80/bin/icc:lang/icc
MPICH_CONFIGURE_ENABLE= parallel
-MPICH_LIB_DEPENDS= libmpi.so.12:net/mpich
+MPICH_LIB_DEPENDS= libmpich.so:net/mpich2
OPTIFLAGS_CFLAGS= -ffast-math
OPTIFLAGS_CXXFLAGS= -ffast-math
@@ -62,6 +67,7 @@ post-patch:
@${REINPLACE_CMD} \
-e 's/-lblas/${BLASLIB}/' -e 's/-llapack/${LAPACKLIB}/' \
-e 's/pthread_join(0,0)/pthread_create(0,0,0,0)/' \
+ -e 's|/usr/bin/wish|${LOCALBASE}/bin/wish|' \
${WRKSRC}/configure
do-build-DOXYGEN-on:
diff --git a/science/mpqc/files/patch-src_lib_chemistry_qc_cints_Makefile b/science/mpqc/files/patch-src_lib_chemistry_qc_cints_Makefile
new file mode 100644
index 000000000000..804cefa5f949
--- /dev/null
+++ b/science/mpqc/files/patch-src_lib_chemistry_qc_cints_Makefile
@@ -0,0 +1,19 @@
+--- src/lib/chemistry/qc/cints/Makefile.orig 2018-07-17 20:59:43 UTC
++++ src/lib/chemistry/qc/cints/Makefile
+@@ -52,13 +52,13 @@ LIBOBJ := $(LIBOBJ:%.cc=%.$(OBJSUF))
+
+ LTLINKLIBOPTS += $(LDFLAGS)
+ ifeq ($(HAVE_LIBINT),yes)
+- LTLINKLIBOPTS += -lint
++ LTLINKLIBOPTS += -L$(PREFIX)/lib -lint
+ endif
+ ifeq ($(HAVE_LIBR12),yes)
+- LTLINKLIBOPTS += -lr12
++ LTLINKLIBOPTS += -L$(PREFIX)/lib -lr12
+ endif
+ ifeq ($(HAVE_LIBDERIV),yes)
+- LTLINKLIBOPTS += -lderiv
++ LTLINKLIBOPTS += -L$(PREFIX)/lib -lderiv
+ endif
+
+ DISTFILES = $(TESTCSRC) $(INC) Makefile
diff --git a/science/mpqc/files/patch-src_lib_util_misc_Makefile b/science/mpqc/files/patch-src_lib_util_misc_Makefile
new file mode 100644
index 000000000000..edc3428a337f
--- /dev/null
+++ b/science/mpqc/files/patch-src_lib_util_misc_Makefile
@@ -0,0 +1,10 @@
+--- src/lib/util/misc/Makefile.orig 2005-05-26 06:00:50 UTC
++++ src/lib/util/misc/Makefile
+@@ -38,6 +38,7 @@ CXXFLAGS := $(CXXFLAGS:-fno-implicit-tem
+
+ TARGET_TO_MAKE = libSCmisc
+ BIN_OR_LIB = LIB
++LTLINKLIBOPTS += -lexecinfo
+
+ CSRC =
+
diff --git a/science/mpqc/files/patch-symmetry__pointgrp.cc b/science/mpqc/files/patch-symmetry__pointgrp.cc
deleted file mode 100644
index 2a5f8722f240..000000000000
--- a/science/mpqc/files/patch-symmetry__pointgrp.cc
+++ /dev/null
@@ -1,10 +0,0 @@
---- src/lib/math/symmetry/pointgrp.cc.orig Wed Feb 21 20:52:39 2001
-+++ src/lib/math/symmetry/pointgrp.cc Fri Apr 27 15:28:50 2001
-@@ -54,6 +54,7 @@
- #include <string.h>
- #include <ctype.h>
- #include <math.h>
-+#include <float.h>
-
- #include <util/misc/formio.h>
- #include <util/state/stateio.h>